*PAT甲级1155 Heap Paths//手动模拟反向先序序列//判断大顶堆小顶堆

该博客介绍了如何通过水平遍历序列判断一棵完全二叉树是否为大顶堆或小顶堆。给定一个整数数组表示树的水平遍历,程序使用深度优先搜索(DFS)策略,从右到左输出所有从根到叶子节点的路径。随后,通过比较父节点和子节点的值来确定堆属性,从而确定树是大顶堆、小顶堆还是非堆。
摘要由CSDN通过智能技术生成

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.
Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.
Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
Sample Input 3:
8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题目大意

给出一棵完全二叉树的水平遍历序列,要求从右到左输出每条从根到叶结点的路径,然后输出是大顶堆还是小顶堆或者不是堆

思路

其实题目不是很难,尤其是题目给出完全二叉树的条件,说明水平遍历序列正好就是树中每个结点从上至下,从左到右存放的顺序。然后再用dfs模拟反向版的先序序列,每次遍历到叶结点就输出路径上的结点,然后回溯,循环往复…思路是有,可惜本人能力实在有限,对递归理解不够深刻,实在写不出反向的先序,还是参考了柳神的做法

#include <iostream>
#include <cstdlib>
#include <vector>
#include <map>
#include <queue>
#include <algorithm>
#include <climits>
#include <set>
using namespace std;
int N, level[1001];
vector<int> temp;
void dfs(int root);
void print();
int main()
{
	cin >> N;
	for (int i = 1; i <= N; i++)
		cin >> level[i];
	dfs(1);
	bool isMin = true, isMax = true;
	for (int i = 2; i <= N; i++)
	{
		if (level[i / 2] > level[i])
			isMin = false;
		if (level[i / 2] < level[i])
			isMax = false;
	}
	if (isMin)
		cout << "Min Heap" << endl;
	else if (isMax)
		cout << "Max Heap" << endl;
	else
		cout << "Not Heap" << endl;
	system("pause");
	return 0;
}
void dfs(int root)
{
	if (root * 2 > N)
	{
		temp.push_back(level[root]);
		if (root <= N)
			print();
		return;
	}
	temp.push_back(level[root]);
	dfs(2 * root + 1);
	temp.pop_back();
	dfs(root * 2);
	temp.pop_back();
}
void print()
{
	for (int i = 0; i < temp.size(); i++)
	{
		if (i != 0)
			cout << " ";
		cout << temp[i];
	}
	cout << endl;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值