PAT甲级1139 First Contact//图的巧妙存储//pair的使用

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.
Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.
After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.
If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.
The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

思路

不太会做,参考了柳神的做法。之前一直在想怎么解决同一个数字有正有负的情况,后来发现题目说了It is guaranteed that each person has only one gender…所以这里的性别其实只是用来区分同性朋友和异性朋友的,区分完后完全可以全部变成正数来处理。柳神的做法是将同性朋友的关系放入邻接表中,然后两两有关系的用一个散列表relation表示。然后利用邻接表寻找A的同性朋友C,再找B的同性朋友D,如果relation[C][D]等于1,说明这条关系线成立,然后继续寻找…注意题目可能有0000和-0000的情况,所以数字最好用string存储

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
int relation[10000][10000];
vector<int> Adj[10000]; //Adj保存同性关系
int N, M, K;
int main()
{
	cin >> N >> M;
	for (int i = 0; i < M; i++)
	{
		string s1, s2;
		cin >> s1 >> s2;
		if (s1.length() == s2.length()) //同性
		{
			int p1 = abs(stoi(s1)), p2 = abs(stoi(s2));
			Adj[p1].push_back(p2);
			Adj[p2].push_back(p1);
		}
		int p1 = abs(stoi(s1)), p2 = abs(stoi(s2));
		relation[p1][p2] = relation[p2][p1] = 1;
	}
	cin >> K;
	for (int i = 0; i < K; i++)
	{
		int A, B;
		cin >> A >> B;
		A = abs(A), B = abs(B);
		vector<pair<int, int>> ans;
		for (int i = 0; i < Adj[A].size(); i++)
		{
			int C = Adj[A][i]; //寻找A的同性朋友
			//这里避免A和B直接认识的情况
			if (C == B) continue;
			for (int j = 0; j < Adj[B].size(); j++)
			{
				int D = Adj[B][j]; //寻找B的同性朋友
				//同上,这里避免B和A直接认识的情况
				if (D == A) continue;
				//如果C和D认识,说明这是一条关系线
				if (relation[C][D])
					ans.push_back({C, D});
			}
		}
		cout << ans.size() << endl;
		sort(ans.begin(), ans.end());
		for (auto p : ans)
			printf("%04d %04d\n", p.first, p.second);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值