Rectangle 四川第七届省赛E

frog has a piece of paper divided into nn rows and mm columns. Today, she would like to draw a rectangle whose perimeter is not greater than kk.
在这里插入图片描述
There are 8 (out of 9) ways when n = m = 2, k = 6

Input

The input consists of multiple tests. For each test:

The first line contains 33 integer n,m,kn,m,k (1≤n,m≤5⋅104,0≤k≤1091≤n,m≤5⋅104,0≤k≤109).

Output

For each test, write 11 integer which denotes the number of ways of drawing.

Sample Input

2 2 6
1 1 0
50000 50000 1000000000

Sample Output

8
0
1562562500625000000

因为没有判断 cnt_x=min(k/2-j,m) 而引发超时

#include<bits/stdc++.h>
using namespace std;
#define maxn 100005
int main()
{
	int n,m,k;
	while(~scanf("%d %d %d",&n,&m,&k)){
		long long sum=0,a[maxn]={0};
		for( int i=1; i<=m; i++ ) a[i]=a[i-1]+m-i+1;//m-i+1表示宽度为i在m列里有几种放置情况,a[i]表示总和;
		for( int j=1; j<=n; j++ ){//高从j到n;
			int cnt_x=min(k/2-j,m);
			if(cnt_x<0) cnt_x=0;
			int cnt_y=n-j+1;//高为j在n列里情况
			sum+=a[cnt_x]*cnt_y;
		}
		printf("%lld\n",sum);
	}	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值