L2-3 玩转二叉树 (25 分)

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

用链表

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1e5+10;
int hea[maxn],mid[maxn],flag=0;
struct dot{
	int self;
	dot *lchi,*rchi;
}temp;
dot* newnode(){return new dot();}
int fun(dot& fa,int l1,int r1,int l2,int r2){
	if(l1>r1) return 0;
	int root=hea[l2];
	int p=l1;
	while(mid[p]!=root) p++;
	int cnt=p-l1;
	fa.self=root;
	dot* left=newnode();dot* right=newnode();
	(*left).self=fun(*left,l1,p-1,l2+1,l2+cnt);
	if((*left).self!=0) fa.lchi=left;
	(*right).self=fun(*right,p+1,r1,l2+cnt+1,r2);
	if((*right).self!=0) fa.rchi=right;
	return root;
}
void bfs(dot root){
	queue<dot>Q;Q.push(root);
	while(!Q.empty()){
		dot buf=Q.front();Q.pop();
		if(buf.rchi!=NULL) Q.push(*buf.rchi);
		if(flag) printf(" ");else flag=1;
		printf("%d",buf.self);
		if(buf.lchi!=NULL) Q.push(*buf.lchi);
	}
		
}
int main(){
	// freopen("input.txt","r",stdin);
	// freopen("output.txt","w",stdout);
	int n;scanf("%d",&n);
	for( int i=0; i<n; i++ ) scanf("%d",&mid[i]);
	for( int i=0; i<n; i++ ) scanf("%d",&hea[i]);
	fun(temp,0,n-1,0,n-1);
	bfs(temp);
	return 0;
}

用数组

#include<bits/stdc++.h>
using namespace std;
#define maxn 10010
int mid[maxn],hea[maxn];
int lchi[maxn],rchi[maxn];
int fun( int l1,int r1,int l2,int r2){
	if(l1>r1) return 0;
	int root=hea[l2];
	int p=l1;
	while(mid[p]!=root) p++;
	int cnt=p-l1;
	lchi[root]=fun(l1,p-1,l2+1,l2+cnt);
	rchi[root]=fun(p+1,r1,l2+cnt+1,r2);
	return root;
}
void bfs(int root){
	queue<int>q;
	int flag=0;
	q.push(root);
	while(!q.empty()){
		int x=q.front();
		q.pop();
		if(flag) cout<<' ';
		cout<<x;flag++;
		if(rchi[x]!=0) q.push(rchi[x]);
		if(lchi[x]!=0) q.push(lchi[x]);
	}
}
int main()
{
	int n,cnt=0;
	cin>>n;
	for( int i=0; i<n; i++ ) cin>>mid[i];
	for( int i=0; i<n; i++ ) cin>>hea[i];
	fun(0,n-1,0,n-1);
	bfs(hea[0]);
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值