【寒假】UVA 424(大数相加)

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of
powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
“This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.”
(Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky
apartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no
VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
Sample Output
370370367037037036703703703670

大数的相加,过程很简单,注意一下细节就好,注意多个零的输入。

#include<iostream>
#include<cstring>
using namespace std;
char c[100005];
int sum[100005];
int a[100005];
int main()
{
	int i = 0;
	cin >> c;//保存输入字符
	int l = 0;//保存最大字符串的长度
	int lc = 0;//保存当前输入字符串的长度
	//int s;
	int k = 1;
	if (c[0] == '0'&&c[1] == '\0')//输入为零且只有一个零
		k = 0;
	lc = strlen(c);
	while (k)
	{
		l = unsigned(l) > strlen(c) ? l : strlen(c);

		for (int i = 0; i < lc; i++)
		{
		
			a[lc - i] = c[i] - '0';//将字符转换成整型

		}
		//for (int i = 1; i <= l; i++)
		//	cout << a[i]<<endl;
		for (int i = 1; i <= l; i++)
		{
			sum[i] += a[i];
			sum[i + 1] += sum[i] / 10;
			sum[i] %= 10;
			//cout << a[i] << '\t' << sum[i] << '\t' << sum[i + 1] << endl;
		}
		//	for (int i = l; i >= 1; i--)
			//	cout << sum[i];
		//	cout << endl;
		if (sum[l + 1] != 0)l++;
		memset(c, '\0', sizeof(c));
		memset(a, 0, sizeof(a));
		cin >> c;
		lc = strlen(c);
		//cout << "lc"<<lc << endl;
		if (c[0] == '0'&&c[1] == '\0')
			k = 0;
	}//if (sum[l] == 0 && sum[l - 1] == 0)cout << 0;
	//else
	for (int i = l; i >= 1; i--)
		cout << sum[i];
	cout << endl;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值