【寒假】POJ 2421 (最小生成树)

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output
179

问题描述:就是先输入村庄之间的距离,然后输入有哪几个村庄是已经连起来的,要新建几条道路将这几个村庄连起来,并要求这几条道路加起来总和最小。

解题思路:Kruskal+压缩并查集,先把所有道路从小到大排序,然后从小到大依次考查每条边。注意要将边的序号和边的两端点序号记下。为了提高效率使用了并查集中的路径压缩,既然每棵树表示的只是一个集合,因此树的形态是无关紧要的,并不需要在“查找”之后保持树的形态不变,只要顺便把遍历过的结点都改成树根的子结点,下次查找就会快很多了。

ac代码:

#include<iostream>
#include<algorithm>
using namespace std;
//int map[1005][1005];
int r[10005];
int u[10005];
int v[10005];
int w[10005];
int p[10005];
int N;
int t;
int k ;
int cmp(const int i, const int j)//间接排序函数
{
	return w[i] < w[j];
}
int find(int x)
{
	return p[x] == x ? x : p[x] = find(p[x]);
}

void Kruskal()
{
	int ans = 0;
	
	for (int i = 0; i < k; i++)//初始化边序号
		r[i] = i+1;
	sort(r, r + k, cmp);
	//for (int i = 0; i < k; i++)
	//	cout << w[r[i]] << endl;
	for (int i = 0; i < k; i++)
	{
		int e = r[i];
		int x = find(u[e]);
		int y = find(v[e]);//找出当前边两个端点所在集合编号,就是说找出根节点。
		if (x != y)//如果在不同集合,合并。
		{
			ans += w[e];
			p[x] = y;
		}
	}
	cout << ans<<endl;
}
int main()
{
	//	for (int i = 0; i < N; i++)
	 //    r[i] = i;

	while (~scanf("%d", &N))
	{
		k = 0;
		for (int i = 1; i <= N; i++)//初始化并查集
			p[i] = i;
		for (int i = 0; i < N; i++)
			for (int j = 0; j < N; j++)
			{
				cin >> t;
				if (i < j)
				{
					++k;
					//	map[i][j] = 1;
					w[k] = t;
					u[k] = i + 1;
					v[k] = j + 1;

				}
			}
		//	cout << k << endl;
		int Q;
		cin >> Q;
		int a, b;
		for (int i = 0; i < Q; i++)
		{
			cin >> a >> b;
			if (find(a) != find(b))
				p[find(a)] = find(b);//一开始直接p[a]=b,wa了好几次,现在想如果之前输入1 2,后面再输入 1 3,这样错误就出来了
		}
		
		Kruskal();
		
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值