POJ2182-Lost Cows

N (2 <= N <= 8,000) cows have unique brands in the range 1…N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.
Input

  • Line 1: A single integer, N

  • Lines 2…N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.
    Output

  • Lines 1…N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.
    Sample Input
    5
    1
    2
    1
    0
    Sample Output
    2
    4
    5
    3
    1

分析:

题意:
有n头牛,他们的编号从1~n,输入第一行一个整数n,然后输入n-1行,都是整数,表示在这头牛的前面有多少头牛的编号小于它的编号,要求输出牛的编号序列。

这道题开始我用的暴力算法,居然过了,耗时400多毫秒,后来上网查了一下,说可以用树状数组维护,所以就重新写了一下,耗时63毫秒!

树状数组不知道的可以百度_!我就不细讲了!

暴力:

#include<cstdio>
#include<iostream>
#define N 10000

using namespace std;

int book[N],tree[N];
bool vist[N];
int n;

int updata(int num)
{
	int sum=0;
	for(int i=1;i<=n;i++)
	{
		if(!vist[i])
		{
			sum++;
			if(sum==num+1)
			{
				vist[i]=true;
				return i;
			}
		}
	}
}

int main()
{
	cin>>n;
	for(int i=2;i<=n;i++)
	{
		scanf("%d",&book[i]);
	}
	for(int i=n;i>1;i--)
	{
		tree[i]=updata(book[i]);
	}
	for(int i=1;i<=n;i++)
	{
		if(!vist[i])
		{
			tree[1]=i;
			break;
		}
	}
	for(int i=1;i<=n;i++)
	{
		printf("%d\n",tree[i]);
	}
	return 0;
}

树状数组:

#include<iostream>
#include<cstdio>
#define N 10005

using namespace std;

int tree[N],book[N];
int n;

int lowbit(int x)
{
	return x&-x;
}

void updata(int x,int v)
{
	while(x<=n)
	{
		tree[x]+=v;
		x+=lowbit(x);
	}
}

int sum(int x)
{
	int sum=0;
	while(x>0)
	{
		sum+=tree[x];
		x-=lowbit(x);
	}
	return sum;
}

int get(int l,int r,int num)
{
	int p,mid,cnt;
	while(l<=r)
	{
		mid=(l+r)>>1;
		int cnt=sum(mid);
		if(cnt>=num)
		{
			p=mid;
			r=mid-1;
		}
		else
			l=mid+1;
	}
	return p;
}

int main()
{
	cin>>n;
	updata(1,1);
	for(int i=2;i<=n;i++)
	{
		scanf("%d",&book[i]);
		updata(i,1);
	}
	for(int i=n;i>=1;i--)
	{
		book[i]=get(1,n,book[i]+1);
		updata(book[i],-1);
	}
	for(int i=1;i<=n;i++)
	{
		printf("%d\n",book[i]);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值