Seiji Hayashi had been a professor of the Nisshinkan Samurai School in the domain of Aizu for a long time in the 18th century. In order to reward him for his meritorious career in education, Katanobu Matsudaira, the lord of the domain of Aizu, had decided to grant him a rectangular estate within a large field in the Aizu Basin. Although the size (width and height) of the estate was strictly specified by the lord, he was allowed to choose any location for the estate in the field. Inside the field which had also a rectangular shape, many Japanese persimmon trees, whose fruit was one of the famous products of the Aizu region known as ‘Mishirazu Persimmon’, were planted. Since persimmon was Hayashi’s favorite fruit, he wanted to have as many persimmon trees as possible in the estate given by the lord.
For example, in Figure 1, the entire field is a rectangular grid whose width and height are 10 and 8 respectively. Each asterisk (*) represents a place of a persimmon tree. If the specified width and height of the estate are 4 and 3 respectively, the area surrounded by the solid line contains the most persimmon trees. Similarly, if the estate’s width is 6 and its height is 4, the area surrounded by the dashed line has the most, and if the estate’s width and height are 3 and 4 respectively, the area surrounded by the dotted line contains the most persimmon trees. Note that the width and height cannot be swapped; the sizes 4 by 3 and 3 by 4 are different, as shown in Figure 1.
Figure 1: Examples of Rectangular Estates
Your task is to find the estate of a given size (width and height) that contains the largest number of persimmon trees.
Input
The input consists of multiple data sets. Each data set is given in the following format.
N
W H
x1 y1
x2 y2
…
xN yN
S T
N is the number of persimmon trees, which is a positive integer less than 500. W and H are the width and the height of the entire field respectively. You can assume that both W and H are positive integers whose values are less than 100. For each i (1 <= i <= N), xi and yi are coordinates of the i-th persimmon tree in the grid. Note that the origin of each coordinate is 1. You can assume that 1 <= xi <= W and 1 <= yi <= H, and no two trees have the same positions. But you should not assume that the persimmon trees are sorted in some order according to their positions. Lastly, S and T are positive integers of the width and height respectively of the estate given by the lord. You can also assume that 1 <= S <= W and 1 <= T <= H.
The end of the input is indicated by a line that solely contains a zero.
Output
For each data set, you are requested to print one line containing the maximum possible number of persimmon trees that can be included in an estate of the given size.
Sample Input
16
10 8
2 2
2 5
2 7
3 3
3 8
4 2
4 5
4 8
6 4
6 7
7 5
7 8
8 1
8 4
9 6
10 3
4 3
8
6 4
1 2
2 1
2 4
3 4
4 2
5 3
6 1
6 2
3 2
0
Sample Output
4
3
分析:
题意:
一个宽为W,高为H的矩形林地里面有N柿子树,现在这块矩形地里取一块宽高都不大于这块林地的地,求这块地里面的柿子树要最多!求最多为多少?
解析:
这个要用到二维的树状数组!以前做过二维树状数组的题,所以一气呵成!没有什么卡顿就过了,但是明明和别人的代码差不多,但别个大佬就是0ms,而我却是16ms,想不通!
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 505
using namespace std;
int tree[N][N];
int w,h;
int lowbit(int x)
{
return x&-x;
}
void updata(int y,int x)
{
int xi;
while(y<=h)
{
xi=x;
while(xi<=w)
{
tree[y][xi]++;
xi+=lowbit(xi);
}
y+=lowbit(y);
}
}
int Sum(int y,int x)
{
int sum=0,xi;
while(y>0)
{
xi=x;
while(xi>0)
{
sum+=tree[y][xi];
xi-=lowbit(xi);
}
y-=lowbit(y);
}
return sum;
}
int query(int y1,int y2,int x1,int x2)
{
int sum=0;
sum+=Sum(y2,x2);
sum-=Sum(y2,x1);
sum-=Sum(y1,x2);
sum+=Sum(y1,x1);
return sum;
}
int main()
{
int n,s,t,x,y,Max;
while(cin>>n&&n)
{
scanf("%d%d",&w,&h);
for(int i=1;i<=n;i++)
{
scanf("%d%d",&x,&y);
updata(y,x);
}
scanf("%d%d",&s,&t);
Max=-1;
for(int i=t;i<=h;i++)
{
for(int j=s;j<=w;j++)
{
Max=max(Max,query(i-t,i,j-s,j));
}
}
printf("%d\n",Max);
memset(tree,0,sizeof(tree));
}
return 0;
}