HDU 2955-Robberies(互斥事件+01背包)

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
2
4
6

分析:

题意:
一个强盗抢银行,第一行一个浮点数Max和一个整数n,分别表示强盗抢K个银行的总概率不能大于他,不然就有危险,n表示银行数;然后是n行,每行一个整数money和一个浮点数pro表示银行的钱和抢这个银行被抓的概率,要求总的被抓的概率不大于Max的情况下,能抢到的最多的钱是多少?

解析:
真的坑,独立事件的概率居然用了加法!而且给的案例算的答案居然相同!
这道题就是抢K个银行被抓的总概率不大于Max所抢到的钱的最大值!独立事件求被抓的概率,但是抢几个银行都不知道,被抓的次数也不知道,所以就有了互斥事件:被抓和一次都没有被抓到是一对互斥事件,所以:
被抓的概率=1-一次都没有被抓的概率;
明白这一点就好了,然后就是简单的01背包!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 105

using namespace std;

struct node{
	int money;
	float pro;
};

node book[N];
float dp[N*N];

int main()
{
	int T,n;
	float Ma;
	scanf("%d",&T);
	while(T--)
	{
		int sum=0;
		scanf("%f%d",&Ma,&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d%f",&book[i].money,&book[i].pro);
			sum+=book[i].money;
		}
		dp[0]=1.0;
		for(int i=1;i<=n;i++)
		{
			for(int j=sum;j>=book[i].money;j--)
			{
				dp[j]=max(dp[j],dp[j-book[i].money]*(1-book[i].pro));
			}
		}
		for(int i=sum;i>=0;i--)
		{
			if(1-Ma<=dp[i])
			{
				printf("%d\n",i);
				break;
			}
		}
		memset(dp,0,sizeof(dp));
	}
	return 0;
 } 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值