1136 A Delayed Palindrome (20 分)

1136 A Delayed Palindrome (20 分)

在这里插入图片描述Input Specification:
Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:
For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

AC代码

#include <algorithm>
#include <iostream>
#include <string>
using namespace std;
string Add(string A, string B);	//字符串形式加和
bool isPalindromic(string C);	//判断是否为回文数
int main() {
	string A, B, C;
	cin >> A;
	if (isPalindromic(A)) { cout << A << " is a palindromic number."; return 0; } //开始即为回文数
	int cnt = 10;
	bool flag = false;
	while (cnt--) {		//仅限十步
		B = A;
		reverse(B.begin(), B.end());	//得到原始数的逆转数
		C = Add(A, B);
		cout << A << " + " << B << " = " << C << endl;		//结果为回文数则结束
		if (isPalindromic(C)) { cout << C << " is a palindromic number."; flag = true; break; }
		A = C;	//继续操作
	}
	if (flag == false) cout << "Not found in 10 iterations.";	//十步内未找到回文数
	return 0;
}
string Add(string A, string B) {
	string C;
	int i = A.size() - 1;
	int Bas = 0, Adv = 0;
	while (i >= 0) {
		Bas = (A[i] - '0') + (B[i] - '0');	//当前位所得值
		C += (Adv + Bas) % 10 + '0';	//当前位终值
		Adv = (Adv + Bas) / 10;		//进位值
		--i;
	}
	if (Adv) C += (Adv + '0');	//若最后仍有进位值
	reverse(C.begin(), C.end());	//逆转得到两数和
	return C;
}
bool isPalindromic(string C) {
	int Len = C.size(), i;
	bool flag = true;
	for (i = 0; i < Len / 2; i++) if (C[i] != C[Len - 1 - i]) flag = false;
	return flag;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值