PAT A1032 Sharing

Description:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

在这里插入图片描述

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤ 1 0 5 10^5 105​​ ), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

  Address Data Next

where A d d r e s s \color{red}{Address} Address is the position of the node, D a t a \color{red}{Data} Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and N e x t \color{red}{Next} Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

注意点

  1. 如果输入起始地址中包含-1,直接输出-1,并返回
  2. 输出结果如果非-1,那么需要输出5位数字,使用%05d表示输出5位数,高位不足用0代替;输出结果如果是-1,那么直接输出-1
  3. 判断完gap正负之后,将gap转为非负数
  4. while循环时,要注意更改循环变量,不然将会死循环
  5. Node table[maxn];其中table为Node*型变量

AC代码

#include <stdio.h>
#include <string.h>
#include <math.h>

typedef struct Node
{
    char data;
    int next;
}Node;

Node table[100000];//table 就代表Node*型指针

int LenofLinklist(int address)
{//给出起始地址计算长度
    int count=1;
    while(table[address].next!=-1)
    {
        address=table[address].next;
        count++;
    }
    return count;
}

int main()
{
    //freopen("input.txt","r",stdin);
    int ad1,ad2,N,i;
    int len1,len2,gap;
    char b;
    int a,c;
    int longad,shortad;
    scanf("%d %d %d",&ad1,&ad2,&N);
    if(ad1==-1||ad2==-1)
    {
        printf("-1");
        return 0;
    }
    for(i=0;i<N;i++)
    {
        scanf("%d %c %d",&a,&b,&c);
        table[a].data=b;
        table[a].next=c;
    }
    len1=LenofLinklist(ad1);
    len2=LenofLinklist(ad2);
    gap=len1-len2;
    if(gap>0)
    {
        longad=ad1;
        shortad=ad2;
    }
    else
    {
        longad=ad2;
        shortad=ad1;
        gap=-gap;//gap<=0,转为非负数
    }
    while(gap>0)
    {
        longad=table[longad].next;
        gap--;//记得加该语句,不然死循环
    }
    while(1)
    {
        if(longad==shortad)break;
        longad=table[longad].next;
        shortad=table[shortad].next;
    }
    if(longad!=-1)printf("%05d",longad);
    else printf("-1");
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值