【PAT甲级】1032 Sharing (25分)

1032 Sharing (25分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

大意

求两条链表的首个共同节点的地址,没有输出-1.

输入:

​ 第一行 包含 两个地址 正整数N

​ (两个地址)两个单词首个节点的地址

​ (正数N)节点总数量

​ 后面N行 Address Data Next

节点地址是5位正整数,-1代表NULL

【例子1】

单词1:LoaDing

单词2:Being

输出i的地址

分析

用结构体存储节点,data是英文字母,next是下一个节点的地址,flag记录第一条链表是否访问过该节点。

遍历第一条链表,将访问过的节点的flag赋值为true。遍历第二条链表,当碰到flag为true的节点即找到了。

注意

  1. 虽然题目是链表处理,但实现程序不一定会用到链表。

  2. 输出必须为5位数,需要规定格式

    printf("%05d\n",i);

    这里不能写成以下(部分AC)

    printf("%d\n",i);

代码

#include<iostream>

using namespace std;

//节点结构体
struct NODE {
    char data;
    int next;
    bool flag;//第一条链表若访问过为true
} n[100000];

int main() {
    int s1,s2,num;//两个单词的起始地址,节点总个数
    scanf("%d %d %d",&s1,&s2,&num);

    /*赋初值*/
    int addr,next;
    char data;
    for(int i=0; i<num; i++) {
        scanf("%d %c %d",&addr,&data,&next);
        n[addr]= {data,next,false};
    }
    /*第一条链表*/
    for(int i=s1; i!=-1; i=n[i].next) {
        n[i].flag=true;
    }
    /*第二条链表*/
    for(int i=s2; i!=-1; i=n[i].next) {
        if(n[i].flag==true) {
            printf("%05d\n",i);
            return 0;
        }
    }
    printf("-1");

    return 0;
}

单词

  • suffix:后缀
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值