PAT A1077 Kuchiguse

Description:

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)

Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

题意:

说了一大堆,就是为了求给定N个字符的最长相同后缀

注意点:

1.在codeblocks里可以使用gets()函数,PAT里却不能编译通过,只能自己写了一个getline()函数用来接收空格的字符串
2.后缀中可以包含空格,不是判断最后一个单词的最长后缀

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#define maxn 1010


//需要使用algorithm下的函数需要加上using namespace std;

void reverse(char s[])
{
    int i=0,j=strlen(s)-1;
    char temp;
    while(i<j)
    {
        temp=s[i];
        s[i]=s[j];
        s[j]=temp;
        i++;
        j--;
    }
}//翻转


void getline(char s[])
{
    int i=0;
    char ch;
    while(1)
    {
        scanf("%c",&ch);
        if(ch!='\n')s[i++]=ch;
        else break;
    }
    s[i]='\0';
}



int main()
{
    //freopen("input.txt","r",stdin);
    int n,i,j;
    scanf("%d",&n);
    getchar();
    char s[n][260];//
    char ans[260];
    for(int i=0;i<n;i++)
    {
        getline(s[i]);//得到s[i]字符串
        if(strlen(s[i])==0)
        {
            printf("nai");
            return 0;
        }
        reverse(s[i]);//翻转s[i]
    }
    for(i=0;i<strlen(s[0])&&i<strlen(s[1]);i++)
    {
        if(s[0][i]!=s[1][i])break;
    }
    int len=i;//得到最初后缀的长度
    for(i=1;i<n;i++)
    {
        for(j=0;j<strlen(s[i])&&j<len;j++)
        {
            if(s[i][j]!=s[0][j])break;
        }
        len=j;//得到新的长度
    }
    if(len==0)printf("nai");
    else
    {
        for(i=0;i<len;i++)
        {
            ans[i]=s[0][i];//ans[i]
        }
        ans[i]='\0';
        reverse(ans);
        printf("%s",ans);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值