UVA-1354 Mobile Computing(枚举二叉树)

Mobile Computing(枚举二叉树)

There is a mysterious planet called Yaen, whose space is 2-dimensional. There are many beautiful
stones on the planet, and the Yaen people love to collect them. They bring the stones back home and
make nice mobile arts of them to decorate their 2-dimensional living rooms.
In their 2-dimensional world, a mobile is defined recursively as follows:
• a stone hung by a string, or
• a rod of length 1 with two sub-mobiles at both ends; the rod is hung
by a string at the center of gravity of sub-mobiles. When the weights
of the sub-mobiles are n and m, and their distances from the center
of gravity are a and b respectively, the equation n × a = m × b holds.
For example, if you got three stones with weights 1, 1, and 2, here are some possible mobiles and
their widths:

Given the weights of stones and the width of the room, your task is to design the widest possible
mobile satisfying both of the following conditions.
• It uses all the stones.
• Its width is less than the width of the room.
You should ignore the widths of stones.
In some cases two sub-mobiles hung from both ends of a rod
might overlap (see the figure on the right). Such mobiles are acceptable. The width of the example is (1/3) + 1 + (1/4).
在这里插入图片描述
Input
The first line of the input gives the number of datasets. Then the specified number of datasets follow.
A dataset has the following format.
r
s
w1
.
.
.
ws
r is a decimal fraction representing the width of the room, which satisfies 0 < r < 10. s is the number
of the stones. You may assume 1 ≤ s ≤ 6. wi
is the weight of the i-th stone, which is an integer. You
may assume 1 ≤ wi ≤ 1000.
You can assume that no mobiles whose widths are between r−0.00001 and r+ 0.00001 can be made
of given stones.
Output
For each dataset in the input, one line containing a decimal fraction should be output. The decimal
fraction should give the width of the widest possible mobile as defined above. An output line should
not contain extra characters such as spaces.
In case there is no mobile which satisfies the requirement, answer ‘-1’ instead.
The answer should not have an error greater than 0.00000001. You may output any numb er of
digits after the decimal point, provided that the ab ove accuracy condition is satisfied.
Sample Input
5
1.3
3
1
2
1
1.4
3
1
2
1
2.0
3
1
2
1
1.59
4
2
1
1
3
1.7143
4
1
2
3
5
Sample Output
-1
1.3333333333333335
1.6666666666666667
1.5833333333333335
1.7142857142857142

题意:求不超过房间宽度的天平的最大宽度。天平悬挂石头保持平衡(左重力*左力臂==右重力*右力臂),天平可以重叠,就像上图。注意这种情况左子树的右边界可能超过右子树的右边界:1554650254005

输入:第一个是样例个数,下一行是房间宽度,下一行是石头个数n,下n行是石头重量

思路:从下往上建树,没有访问过的树自由组合,两子树合并在一起后,被合并的树设置已访问

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
double room_w, ans = -1;
struct node{
    double w,l,r;
}arr[10];
bool vis[10];
int n;
void init(){
    ans = -1;
    for(int i = 0; i < 10; i++) {arr[i].l=arr[i].r=arr[i].w=0;}
    memset(vis,false,sizeof(vis));
    scanf("%lf%d",&room_w,&n);
    for(int i = 1; i <= n; i++)
        scanf("%lf",&(arr[i].w));
}
node unin(node n1, node n2){//n1为左子树,n2为右子树
    double l1 = n1.l, l2 = n2.l, r1 = n1.r, 
    r2 = n2.r, w1 = n1.w, w2 = n2.w;
    n1.l = max(l1, l2-1)+w2/(w1+w2);
    n1.r = max(r2, r1-1)+w1/(w1+w2);
    n1.w += w2;
    return n1;
}
void build(int level){
    if(level == n-1){
        int i;
        for(i = 1; i <= n; i++)
            if(!vis[i]) break;
        if(arr[i].l+arr[i].r <= room_w && arr[i].l+arr[i].r > ans)
            ans = arr[i].l+arr[i].r;
        return;
    }
    node n1,n2;
    for(int i = 1; i <= n; i++){//(左子树)自由组合建树
        if(vis[i]) continue;
        for(int j = 1; j <= n; j++){//(右子树)
            if(vis[j] || j == i) continue;
            vis[j] = true;//右子树被合并,设置已访问。
            n1 = arr[i];
            n2 = arr[j];
            arr[i] = unin(n1,n2);//把n1,n2合并到左子树上
            build(level+1);
            vis[j] = false;//还原访问
            arr[i] = n1;//arr[i]还原
        }
    }
}
int main(){
    int N;scanf("%d",&N);
    while(N--){
        init();
        build(0);
        if(ans == -1)
            printf("-1\n");
        else 
            printf("%.16f\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值