Monkey and Banana

Monkey and Banana
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12486    Accepted Submission(s): 6527


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output
Case 1: maximum height = 40

Case 2: maximum height = 21

Case 3: maximum height = 28

Case 4: maximum height = 342
解题

刚开始,一点头绪都没有。睡了一觉,看了一部《流浪地球》。早上醒来开始想。

既然是下面的每一层都比上面大,何不把其按面积大小排个序。然后从头开始往后挑。挑的时候注意一下(bs[i].w>bs[j].w&&bs[i].l>bs[j].l)      ||         (bs[i].w>bs[j].l&&bs[i].l>bs[j].w)有两种能。

然后就是dp 最长递增子序列那一套。

#include<iostream>
#include<map>
#include<cstdio>
#include<memory.h>
#include<algorithm>
#include<cstdlib>
using namespace std;
typedef struct bx
{
    int h,w,l,area;
} box;
int cmp(box a,box b)
{
    return a.area<b.area;
}
int main()
{
    int n,k=1;
    box bs[92];
    while(scanf("%d",&n),n!=0)
    {
        int h,w,l;
        for(int i=0; i<3*n;)
        {
            scanf("%d%d%d",&h,&w,&l);//一个正方体有三种可能。
            bs[i].h=h;
            bs[i].l=l;
            bs[i].w=w;
            bs[i++].area=w*l;
            bs[i].h=w;
            bs[i].l=h;
            bs[i].w=l;
            bs[i++].area=h*l;
            bs[i].h=l;
            bs[i].l=w;
            bs[i].w=h;
            bs[i++].area=w*h;
        }
        n*=3;
        sort(bs,bs+n,cmp);

        int maxm[92];
        for(int i=0; i<n; i++)
            maxm[i]=bs[i].h;
//            for(int i=0;i<n;i++)
//            cout<<maxm[i]<<endl;
        for(int i=1; i<n; i++)
        {

            for(int j=0; j<i; j++)
            {
                if((bs[i].w>bs[j].w&&bs[i].l>bs[j].l)||(bs[i].w>bs[j].l&&bs[i].l>bs[j].w))//注意判断的时候横着放不行的话,可以旋转90度。
                    maxm[i]=max(maxm[i],maxm[j]+bs[i].h);//最长递增子序列那一套

            }
        }

        cout<<"Case "<<k++<<": maximum height = "<<*max_element(maxm,maxm+n)<<endl;
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值