PAT甲级 1003 Emergency

PAT甲级 1003 Emergency

题目描述

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​ , c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2
​​ .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​ , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:
2 4

题目主要意为每个城市的救援队伍已知和城市间的路长已知,实质去求解最短路径方案的个数,以及能够得到的最多救援队数量。

对于最短路径的求解,将采用邻接矩阵存放路径,利用回溯法求解最短路径。回溯法作为一种穷举式搜索法,思想也便于理解。

解决方法如下:

#include<iostream>
using namespace std;
int length=1000000;
int count_team=0;             
int count_shortest=0;
//参数依次为 所在城市 目的城市 城市数量 visit中若为1则代表访问过 邻接矩阵 城市中的救援队数量 救援队数量 最短路径长
void getLength(int index,int target,int N,int *visit,int len[500][500],int *rescue,int c,int L){
	if(index==target){
        c+=rescue[index];
		if(length>L){              //若得到更短的路径 就更新数据
			count_team=c;
			length=L;
			count_shortest=1;
            return;
		}else if(length==L){          //得到了另一种最短路径方案 
			count_shortest++;
			count_team=c>count_team?c:count_team;
            return;
        }
	}
	for(int i=0;i<N;i++){
		if(len[index][i]>0&&visit[i]==0){
			L+=len[index][i];
			visit[index]=1;
			c+=rescue[index];
			getLength(i,target,N,visit,len,rescue,c,L);
			L-=len[index][i];
			visit[index]=0;
			c-=rescue[index];
		}
	}
}
int main(){
	int N,M,C1,C2;
	cin>>N>>M>>C1>>C2;
	int len[500][500],rescue[500],visit[500]={0};
	int i,j;
	for(i=0;i<N;i++){
		int n;
		cin>>n;
		rescue[i]=n;                   //救援队数量
		for(j=0;j<N;j++)
			len[i][j]=0;               //邻接矩阵
	}
	for(i=0;i<M;i++){
		int c1,c2,l;
		cin>>c1>>c2>>l;
		len[c1][c2]=l;
		len[c2][c1]=l;
	}
	int L=0,c=0;
	getLength(C1,C2,N,visit,len,rescue,c,L);
	cout<<count_shortest<<" "<<count_team;
	return 0;
}

处理结果:
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值