PAT甲级 1004 Counting Leaves

PAT甲级 1004 Counting Leaves

问题描述

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02

Sample Output:
0 1

题目分析

首先题中表明会给出结点数和非叶结点数,且根节点定为01,要求输出每一层的叶子结点数。

输入格式:
结点总数 非叶结点数
父结点 子结点数 子结点

输出格式:
依次输出第i层叶子结点数

解决方法:

#include<iostream>
using namespace std;
int level[100]={0};               //每个结点的层级
void getLevel(int node[100][100],int father){
    for(int i=0;i<100;i++){
        if(node[father][i]!=0){
            level[node[father][i]]=level[father]+1;
            getLevel(node,node[father][i]);     //递归调用
        }else{
            return;
        }
    }
}
int getMax(int *level){
    int max=level[0];
    for(int i=1;i<100;i++){
        if(max<level[i]){
            max=level[i];
        }
    }
    return max;
}
int main(){
    int N,M;                       //总结点数、非叶结点数
    cin>>N>>M;
    int node[100][100]={0};            //存放每一层的叶子节点数
    for(int i=0;i<M;i++){
        int father,count;
        cin>>father>>count;
        for(int k=0;k<count;k++){
            cin>>node[father][k];   //存放每个结点的结点
        }
    }
    level[1]=1;
    getLevel(node,1);
    int count[100]={0};            //每层的叶子结点数
    for(int i=1;i<=N;i++){
        if(node[i][0]==0){
            count[level[i]]++;
        }
    }
    int max=getMax(level);
    for(int i=1;i<max;i++){
        cout<<count[i]<<" ";
    }
    cout<<count[max]<<endl;
    return 0;
}

处理结果:
在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值