POJ 3104:二分

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input
The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output
Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5
Sample Output
sample output #1
3

sample output #2
2

题解:
二分烘干衣服的时间。
需要注意一个细节:
每件衣服烘干所用的时间是(a[i]-,mid)/(k-1),当k=1的时候需要特判一下。

#include<iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
typedef long long ll;
using namespace std;
	ll n,k,l=1,r=0,mid;
ll a[100005];
bool judge(ll x){
	ll m=0;
	for(int i=1;i<=n;i++)
		if(x<a[i]) m+=ceil((a[i]-x)*1.0/(k-1));
	return m<=x;
	
	
	
} 
int main()
{
	scanf("%lld",&n);
	for(int i=1;i<=n;i++)
		{
			scanf("%lld",&a[i]);
		
			}
	scanf("%lld",&k);
	
	sort(a+1,a+1+n);
	r=a[n];
	if(k==1) {
	printf("%lld\n",r);
	return 0;	
}
	while(r-l>1)
	{	mid=(l+r)/2;
		if(judge(mid)) r=mid;
		else l=mid;
		}
	printf("%lld\n",r);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

轩辕青山

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值