hdu 2674:N!Again【打表找规律】

Discription
WhereIsHeroFrom: Zty, what are you doing ?
Zty: I want to calculate N!..
WhereIsHeroFrom: So easy! How big N is ?
Zty: 1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?
Zty: No. I haven’s finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.

Output
For each case, output N! mod 2009

Sample Input

4 
5

Sample Output

24
120

题意
求n的阶乘,模2009。
n的范围为1e9

思路
1e9直接求,必然超时,这个时候,就需要用到万能的打表了。
由打表的值知,不能整除2009的数不超过50个,50之后全为0.
预处理一下输出就行了

AC代码

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int mod=2009;

LL n,ans;
LL tmp[100000000];

void F()
{
    tmp[0]=1;
    for(int i=1; i<=50; i++)
        tmp[i]=(i%mod*tmp[i-1]%mod)%mod;
    /*for(int i=1; i<=50; i++)
        cout<<tmp[i]<<endl;*/
}

int main()
{
    F();
    while(scanf("%lld",&n)!=EOF)
    {
        if(n<=50)
            cout<<tmp[n]<<endl;
        else
            cout<<0<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值