N!Again 【打表找规律】【思维】

N!Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4008 Accepted Submission(s): 2152

Problem Description
WhereIsHeroFrom: Zty, what are you doing ?
Zty: I want to calculate N!……
WhereIsHeroFrom: So easy! How big N is ?
Zty: 1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?
Zty: No. I haven’s finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.

Output
For each case, output N! mod 2009

Sample Input
4
5

Sample Output
24
120
思路: 数字给的太大了。可能有规律,就打了个表看看
打表代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#define M  10000
#define MOD 2009
#define LL long long
int main()
{
    int n;
    n=50;
    LL i,j;
    LL s=1;
    for(i=1;i<200;i++)
    {
        s=s*i%MOD;
        printf("%lld\t",s);
     }

}

看了输出就能够看到,经过某一项之后都是0
同时根据 同余定理 ,可知道 其中有一项(41!)肯定是可以整除2009 的;
代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#define M  10000
#define MOD 2009
#define LL long long
int main()
{
     LL n;
     while(~scanf("%lld",&n))
     {
        if(n>=41) printf("0\n");
        else
        {
            int i;LL ans=1;
            for(i=1;i<=n;i++) ans=(ans*i)%MOD;
            printf("%lld\n",ans);
          }
      }
      return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值