POJ 1745 Divisibility(背包)

Description
Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16
17 + 5 + -21 - 15 = -14
17 + 5 - -21 + 15 = 58
17 + 5 - -21 - 15 = 28
17 - 5 + -21 + 15 = 6
17 - 5 + -21 - 15 = -24
17 - 5 - -21 + 15 = 48
17 - 5 - -21 - 15 = 18
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5±21-15=-14) but is not divisible by 5.

You are to write a program that will determine divisibility of sequence of integers.

Input
The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space.
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it’s absolute value.

Output
Write to the output file the word “Divisible” if given sequence of integers is divisible by K or “Not divisible” if it’s not.

Sample Input
4 7
17 5 -21 15

Sample Output
Divisible

题意
给出n个数,要求n个数之间任意选择加减,求解是否存在一个最后的结果能被k整除

代码

#include <iostream>
#include <cstdio>
#include <string.h>
#define MAXN 10005
using namespace std;
int dp[MAXN][105],a[MAXN];dp[i][j]表示前i个数进行混合运算的结果对k取模是否为j,若是就为1,否则为0
int n,k;
int abc(int x)
{
    if(x>=0)
        return x;
    else
        return -x;
}//将所有的数都转化为正数;
int main(void)
{
    memset(dp,0,sizeof(dp));//将dp清空
    cin>>n>>k;
    for(int i=1; i<=n; i++)
    {
        cin>>a[i];
        a[i]=abc(a[i])%k;//将数据取模并且对k取余
    }
    dp[1][a[1]%k]=1;
    for(int i=2; i<=n; i++)
        for(int j=0; j<k; j++)
            if(dp[i-1][j])
            {
                dp[i][abc(j+a[i])%k]=1;
                dp[i][abc(j-a[i])%k]=1;
            }/判断所有的数进行相加减后得到的情况能否整除k
    if(dp[n][0]!=0)
        cout<<"Divisible"<<endl;
    else
        cout<<"Not divisible"<<endl;//输出结果
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值