php 消息队列之安装think-queue: composer require topthink/think-queue遇到的错误

准备下载

最开始使用composer官网作为packagist,下载超时,科学上网也安装不了

[Composer\Downloader\TransportException]
  curl error 28 while downloading https://repo.packagist.org/p2/symfony/process.json: Timeout was reached

将地址换为国内镜像(全局 去点 -g 就是只当前项目)

composer config -g repo.packagist composer https://packagist.phpcomposer.com

然后执行

composer require topthink/think-queue

发现没有think-queue,这个包。

再切换成最后将packagit换成阿里云的地址:

 全局配置阿里云镜像:

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

仅当前工程:

c
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值