Week15—魔咒功能对应输出

问题描述

ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题
题库格式:[魔咒] 对应功能
背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能
ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”
【输入】
首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
【输出】
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”
【样例输入】

[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

【样例输出】

light the wand
accio
what?
what?

问题分析

[英文] 翻译,求出英文哈希值为 Hash1,翻译为 Hash2
建立两个 map,直接map[string,string]的话会超时
map[Hash1] = index,s1[index] = 翻译
map[Hash2] = index,s2[index] = 英文
根据查询判断是 [英文] 还是 翻译,然后再在对应的 map 中查询即可

关于字符串读入的一些注意事项
1、cin的输入字符串问题 >> 是会过滤掉不可见字符(如 空格 回车,TAB 等)
2、 scanf() 读取字符串时以空格为分隔,遇到空格就认为当前字符串结束了,所以无法读取含有空格的字符串。
3、gets() 认为空格也是字符串的一部分,只有遇到回车键时才认为字符串输入结束,所以,不管输入了多少个空格,只要不按下回车键,对 gets() 来说就是一个完整的字符串。换句话说,gets() 用来读取一整行字符串。
4、注意处理回车在缓冲区的问题
在这里插入图片描述

代码

#include<iostream>
#include<map>
#include<string>
const long long  mod = 1e9 + 7;
using namespace std;

int Hash(string s)
{
	int sum = 0;
	int seed = 17;
	for (int i = 0; i < s.length(); i++)
	{
		sum = (sum + s[i] * seed) % mod;
		seed = seed * 17 % mod;
	}
	return sum;
}

map<int, int> m1, m2;
string s, a[200010], b[200010];
int main()
{
	
	int k = 0, n;
	string s1, s2;
	 while(getline(cin,s))//不能用scanf 
	{
		if(s=="@END@") break; 
		s1 = s.substr(1, s.find(']') - 1);
		s2 = s.substr(s.find(']') + 2, s.length() - 1);
		int hash1 = Hash(s1);
		int hash2 = Hash(s2);
		m1[hash1] = k;
		a[k] = s2;
		m2[hash2] = k;
		b[k] = s1;
		k++;
	}
	cin >> n;
	getchar();
	for (int i = 1; i <= n; i++)
	{
	    getline(cin,s); 
		if (s[0] == '[')//给出英文 
		{
			s1 = s.substr(1, s.find(']') - 1);
			int hash1 = Hash(s1);
			map<int, int>::iterator it;
			it = m1.find(hash1);
			if (it != m1.end())
				cout << a[m1[hash1]] << endl;
			else
				cout << "what?" << endl;
		}
		else
		{
			int hash2 = Hash(s);
			map<int, int>::iterator it;
			it = m2.find(hash2);
			if (it != m2.end())
				cout << b[m2[hash2]] << endl;
			else
				cout << "what?" << endl;
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值