E - Easier Done Than Said?

E - Easier Done Than Said? 

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

 

Input

The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

Sample Output

<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.

 

判读条件
1:有元音字母
2:不能三个连续元音或辅音
3.不能连续两个相同的字母,除非ee或oo
这道大佬们口中的水题,我写了好长时间运行一直出错,I'm so vegetables呜呜~~~~(>_<)~~~~

由if(flag)引发的惨案╮(╯▽╰)╭直接上代码

 

#include<stdio.h>
#include<string.h>
int yuan(char c)//定义函数判断字母是否是元音
{
	if(c=='a'||c=='e'||c=='i'||c=='o'||c=='u')
	return 1;
	return 0;
}
int main()
{
	char s[10000];
	int l,i;
	while(~scanf("%s",s)&&strcmp(s,"end"))
	{
		int flag=1;
		l=strlen(s);
		for(i=0;i<l;i++)
		{
			if(yuan(s[i]))
			break;//是元音终止循环 
		}
		if(i>=l)
		flag=0;
	
		for(i=1;i<l;i++)
		{
			if(!flag) break;
			if(s[i]==s[i-1])
			{
				if(s[i]=='o'||s[i]=='e')
				continue;
				else
				flag=0;
			} 
		
		}
		
		for(i=2;i<l;i++)
		{
			if(!flag) break;
			if(yuan(s[i])&&yuan(s[i-1])&&yuan(s[i-2]))//连续三个元音 
			flag=0;
			else if(!yuan(s[i])&&!yuan(s[i-1])&&!yuan(s[i-2]))//连续三个辅音 
			flag=0;
		}
		if(flag)
		printf("<%s> is acceptable.\n",s);
		else
		printf("<%s> is not acceptable.\n",s);	
	}
	return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值