专题训练二 搜索进阶 HDU - 3085 Nightmare Ⅱ (双向BFS + 曼哈顿距离)

HDU - 3085 Nightmare Ⅱ (双向BFS + 曼哈顿距离)

Problem Description
Last night, little erriyue had a horrible nightmare. He dreamed that he and his girl friend were trapped in a big maze separately. More terribly, there are two ghosts in the maze. They will kill the people. Now little erriyue wants to know if he could find his girl friend before the ghosts find them.
You may suppose that little erriyue and his girl friend can move in 4 directions. In each second, little erriyue can move 3 steps and his girl friend can move 1 step. The ghosts are evil, every second they will divide into several parts to occupy the grids within 2 steps to them until they occupy the whole maze. You can suppose that at every second the ghosts divide firstly then the little erriyue and his girl friend start to move, and if little erriyue or his girl friend arrive at a grid with a ghost, they will die.
Note: the new ghosts also can devide as the original ghost.

Input
The input starts with an integer T, means the number of test cases.
Each test case starts with a line contains two integers n and m, means the size of the maze. (1<n, m<800)
The next n lines describe the maze. Each line contains m characters. The characters may be:
‘.’ denotes an empty place, all can walk on.
‘X’ denotes a wall, only people can’t walk on.
‘M’ denotes little erriyue
‘G’ denotes the girl friend.
‘Z’ denotes the ghosts.
It is guaranteed that will contain exactly one letter M, one letter G and two letters Z.

Output
Output a single integer S in one line, denotes erriyue and his girlfriend will meet in the minimum time S if they can meet successfully, or output -1 denotes they failed to meet.

Sample Input
3
5 6
XXXXXX
XZ…ZX
XXXXXX
M.G…

5 6
XXXXXX
XZZ…X
XXXXXX
M…
…G…

10 10

…X…
…M.X…X.
X…
.X…X.X.X.
…X
…XX…X.
X…G…X
…ZX.X…
…Z…X…X

Sample Output
1
1
-1

思路:双向BFS + 曼哈顿距离
每次从M出发,一个单位时间走三步,从G出发,一个单位时间走一步,只要其中一个人走到了另一个人走过的地方就算相遇。假设在times时刻,erriyue和his girl friend相遇,那么如果此时他们中任何一人与魔鬼的曼哈顿距离小于2*times(魔鬼能够走的路程, 魔鬼一次往外扩张2步),那么他们将在相遇前被魔鬼吃掉,反之则可以相遇

#include<bits/stdc++.h>
using namespace std;
int n, m, times;
char mp[810][810];
struct node {
	int x, y;
	node(){};
	node(int x, int y) : x(x), y(y) {};
};
node mm, gg, zz[2]; //erriyue, his girl friend, two ghosts
queue<node> q[2];
bool vis[810][810][2];
int dir[][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};
int Manhattan_Dis(int xx1, int yy1, int xx2, int yy2) { //曼哈顿距离 
	return abs(xx1 - xx2) + abs(yy1 - yy2);
}
bool check(int x, int y) {
	if(x >= 0 && x < n && y >= 0 && y < m && mp[x][y] != 'X') {
		if(Manhattan_Dis(x, y, zz[0].x, zz[0].y) <= 2 * times) return false;
		if(Manhattan_Dis(x, y, zz[1].x, zz[1].y) <= 2 * times) return false;
		return true;
	}
	return false;
}
bool bfs(int c) {
	int sz = q[c].size();
	while(sz--) {
		node cur = q[c].front(); q[c].pop();
		int x = cur.x, y = cur.y;
		if(!check(x, y)) continue;
		for(int i = 0; i < 4; i++) {
			int nx = x + dir[i][0], ny = y + dir[i][1];
			if(check(nx, ny) && !vis[nx][ny][c]) {
				if(vis[nx][ny][!c]) return true;
				vis[nx][ny][c] = true;
				q[c].push(node(nx, ny));
			}
		}
	}
	return false;
}
int solve() {
	memset(vis, false, sizeof(vis));
	while(!q[0].empty()) q[0].pop();
	while(!q[1].empty()) q[1].pop(); 
	q[0].push(mm); q[1].push(gg);
	vis[mm.x][mm.y][0] = vis[gg.x][gg.y][1] = true;
	times = 0;
	while(!q[0].empty() || !q[1].empty()) {
		times++;
		if(bfs(0)) return times;
		if(bfs(0)) return times;
		if(bfs(0)) return times;
		if(bfs(1)) return times;
	}
	return -1;
}
int main() {
	ios::sync_with_stdio(false);
	int t; cin >> t;
	while(t--) {
		cin >> n >> m;
		int cnt = 0;
		for(int i = 0; i < n; i++) {
			for(int j = 0; j < m; j++) {
				cin >> mp[i][j];
				if(mp[i][j] == 'M') mm = node(i, j);
				else if(mp[i][j] == 'G') gg = node(i, j);
				else if(mp[i][j] == 'Z') {
					zz[cnt++] = node(i, j);
				}
			}
		}
		cout << solve() << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值