专题训练二 搜索进阶 HDU - 1067 Gap (BFS + map映射)

HDU - 1067 Gap

Problem Description
Let’s play a card game called Gap.
You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card.

First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout.

Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: “11” to the top row, “21” to the next, and so on.

Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout.

At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of “42” is “43”, and “27” has no successor.

In the above layout, you can move “43” to the gap at the right of “42”, or “36” to the gap at the right of “35”. If you move “43”, a new gap is generated to the right of “16”. You cannot move any card to the right of a card of value 7, nor to the right of a gap.

The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows.

Your task is to find the minimum number of moves to reach the goal layout.

Input
The input starts with a line containing the number of initial layouts that follow.

Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards.

Output
For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout, produce “-1”.

Sample Input
4

12 13 14 15 16 17 21
22 23 24 25 26 27 31
32 33 34 35 36 37 41
42 43 44 45 46 47 11

26 31 13 44 21 24 42
17 45 23 25 41 36 11
46 34 14 12 37 32 47
16 43 27 35 22 33 15

17 12 16 13 15 14 11
27 22 26 23 25 24 21
37 32 36 33 35 34 31
47 42 46 43 45 44 41

27 14 22 35 32 46 33
13 17 36 24 44 21 15
43 16 45 47 23 11 26
25 37 41 34 42 12 31

Sample Output
0
33
60
-1

思路:将状态转换成string, 用map映射, 然后使用常规BFS即可解决

#include<bits/stdc++.h>
using namespace std;
int cell[4][10];
char buff[256];
string start = "", goal = "";
struct node {
	string s;
	int step;
	node(){};
	node(string s, int step) : s(s), step(step) {}; 
};
void Play(string s) { //打印, 调试时使用的, 可以删去 
	for(int i = 0; i < 4 * 8 * 2; i += 2) {
		if(i % 16 == 0) cout << endl;
		cout << s[i] << s[i+1] << " ";
	}
	cout << endl;
}
string move(string s, int pos) {
	string ans;
	ans = s;
	for(int i = 0; i < 4 * 8 * 2; i += 2) {
		if(s[i] == s[pos-2] && s[i+1] == s[pos-1] + 1) {
			ans[i] = '0', ans[i+1] = '1';
			ans[pos] = s[pos-2], ans[pos+1] = s[pos-1] + 1;
			return ans;
		}
	}
}
void bfs() {
	map<string, bool> vis; //映射, 判重 
	queue<node> q;
	q.push(node(start, 0));
	vis[start] = true;
	while(!q.empty()) {
		node cur = q.front(); q.pop();
		string s = cur.s; int step = cur.step;
		if(s == goal) {
			cout << step << endl;
			return ;
		}
		for(int i = 0; i < 4 * 8 * 2; i += 2) {
			if(s[i] == '0' && s[i+1] == '1') {
				if(i % 16 == 0 || (s[i-2] == '0' && s[i-1] == '1') || s[i-1] == '7') 
					continue;
				string ns = move(s, i);
				//Play(ns);
				if(!vis[ns]) {
					vis[ns] = true;
					q.push(node(ns, step+1));
				}
			}
		}
	}
	cout << "-1" << endl;
	return ;
}
int main() {
	for(int i = 1; i <= 4; i++) {
		for(int j = 1; j <= 7; j++) {
			sprintf(buff, "%d", i*10+j);
			goal += buff;
		}
		goal += "01"; //空格
	}
	int t; cin >> t;
	while(t--) {
		for(int i = 0; i < 4; i++) {
			for(int j = 1; j < 8; j++) {
				int x; cin >> x;
				cell[i][j] = (x % 10 == 1) ? 1 : x; //空格设为1 
			}
		}
		cell[0][0] = 11, cell[1][0] = 21, cell[2][0] = 31, cell[3][0] = 41;
		start = ""; //将表格存为字符串,便于hash
		for(int i = 0; i < 4; i++) {
			for(int j = 0; j < 8; j++) {
				sprintf(buff, "%02d", cell[i][j]); //%02d 便于存储空格"01" 
				start += buff;
			}
		}
		//Play(start);
		bfs();
	}
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值