题解:Saruman's Army(贪心)

该问题描述了Saruman如何使用最大范围为R的监视石(palantirs)来确保军队中的每个士兵都在其监视范围内。输入包含多个测试用例,每个用例包括R值、士兵数量n以及士兵的位置。输出是最小的palantirs数量。示例解释了如何应用贪心策略解决问题,例如从前往后放置palantirs,确保覆盖所有士兵,而不能让palantirs悬空。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.
Input
The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.
Output
For each test case, print a single integer indicating the minimum number of palantirs needed.
Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1
Sample Output
2
4
Hint
In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.
In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.
简单贪心,从前往后,每次最远

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <time.h>
#include <algorithm>
typedef long long ll;
using namespace std; 
int minn[1010],maxn[1010];
bool weizhi[1010];
int main()
{
    int n,r,tmp;
    while(cin>>r>>n)
    {
     memset(weizhi,0,sizeof(weizhi));
     if(r==-1&&n==-1) break;
     int sum=0;
     for(int i=1;i<=n;i++)
     {
     	cin>>tmp;weizhi[tmp]=1;
	 }
	 for(int i=0;i<=1000;i++)
	  if(weizhi[i])
	  {
	  	sum++;
	  	for(int j=i+r;j>=i;j--)
	  	 if(weizhi[j])
	  	 {
	  	  for(int k=i;k<=j+r;k++)
			weizhi[k]=0;
		  break;	
		 }
	  }
	 cout<<sum<<endl;
	}
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值