[HDOJ 1020] Encoding 字符串编码 (杭电OJ第1020题)

Encoding
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.
  2. If the length of the sub-string is 1, ‘1’ should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input
2
ABC
ABBCCC

Sample Output
ABC
A2B3C

思路:简单字符串编码问题,只要求统计连续相同的字符,好多人有个误区,求一个字符串中所有相同的字符,这样直接WA掉了。
        通过前一个字符与紧跟其后的字符进行对比,设定一个num用来记录相同的个数。初始时num为1。比较若干次后如果num<=1则不输出数字,反之输出。
Time:0MS Memory:208K Code Length:416B

#include <stdio.h>
#include <string.h>
int main(){
    int n,i,num;
	char str[10001];//题目要求是10000个字符,我们要开大一点
	scanf("%d",&n);
	while(n--){
		num=1;
		scanf("%s",str);
	  for(i=0;i<strlen(str);i++){
		  if(str[i]==str[i+1]){ //如果一个字符跟它后面的字符相同则num++;
                          num++;
		  }
		  else{
		       if(num<=1) {
		    printf("%c",str[i]);
		    num=1;}//记住num要重置为1,不然残留后会导致后面出现错误
			  else{
                       printf("%d%c",num,str[i]);
	  	    num=1;}
		  }
	  }printf("\n");
	}return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值