CD

传送门

题面:

CD

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.

Assumptions:

number of tracks on the CD. does not exceed 20
no track is longer than N minutes
tracks do not repeat
length of each track is expressed as an integer number
N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input

Any number of lines. Each one contains value N, (after space) number of tracks M and durations of the tracks. For example from first line in sample data: N=5, M=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

The input data satisfies the following constraints:

N≤10000
M≤20

Output

Set of tracks (and durations) which are the correct solutions and string ``sum:" and sum of duration times.

Sample Input

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2

Sample Output

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45

题面描述:

有一张最多可以放n分钟曲目的磁带与多张cd,现在要从CD中选择曲目以充分利用磁带空间并尽可能缩短未使用的空间,CD上的曲目数量不超过20个,没有曲目超过N分钟,曲目不重复,每个轨道的长度表示为整数,n也是整数,顺序打印放入的每个曲目。

题目分析:

01背包问题:每种物品有两个选择,放或者不放,主要看状态转移方程。

代码:

#include<algorithm>
#include<stdio.h> 
#include<iostream>
#include<string.h> 
#include<queue>
#include<vector>
using namespace std;
int m,n,i,j,t,a[20],dp[10005],b[10005];//尝试一维做法 

int main(){
	while(cin>>n>>m){
		memset(dp,0,sizeof(dp));
		memset(b,0,sizeof(b));
		for(i=0;i<m;i++) cin>>a[i];//看状态转移方程的区别,可以不用从1开始 
		for(i=0;i<m;i++){
			for(j=n;j>=a[i];j--){//从大到小是01背包 
				if(dp[j]<dp[j-a[i]]+a[i]){
					dp[j]=dp[j-a[i]]+a[i];
					b[j]=a[i];//只有拿了a[i]才会记下,然后一个个回推 
				}//因为是一维所以不拿的情况就是原来的情况 
			}
		}
		t=dp[n],i=0;
		while(b[t]!=0){ 
			a[i++]=b[t];
			t=t-b[t];
		}
		for(i;i>0;i--) cout<<a[i-1]<<' ';
		cout<<"sum:"<<dp[n]<<endl;
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Yjonben

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值