PAT甲级1009 Product of Polynomials 测试点0未解决

1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ … N​K​​ a​N​K​​​​where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

注意:

虽然题目中说K是表示非零项的数量,但是仍然要考虑当系数为零的情况,当系数为0时相应的项不输出,在计算非零项的数目时也不能加入。
但是我考虑了这一点后,测试点0还是不能通过,不知道为什么,路过的大佬们可以帮我康康,谢谢~

代码如下:

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Comparator;
import java.util.HashMap;
import java.util.Map;
import java.util.TreeMap;

public class ProductOfPolynomials {

    public static void main(String[] args) throws IOException {
        BufferedReader bufferedReader = new BufferedReader(new InputStreamReader(System.in));
        Map<Integer, Float> poly1 = new HashMap<>();
        Map<Integer, Float> poly2 = new HashMap<>();
        String[] strArr1 = bufferedReader.readLine().split(" ");
        String[] strArr2 = bufferedReader.readLine().split(" ");
        for (int i = 1; i < strArr1.length - 1; i += 2)
            poly1.put(Integer.parseInt(strArr1[i]), Float.parseFloat(strArr1[i + 1]));
        for (int i = 1; i < strArr2.length - 1; i += 2)
            poly2.put(Integer.parseInt(strArr2[i]), Float.parseFloat(strArr2[i + 1]));
        Map<Integer, Float> result = new TreeMap<>(new Comparator<Integer>() {
            @Override
            public int compare(Integer o1, Integer o2) {
                return o2 - o1;
            }
        });
        for (Map.Entry<Integer, Float> entry1 : poly1.entrySet()) {
            for (Map.Entry<Integer, Float> entry2 : poly2.entrySet()) {
                int rExponent = entry1.getKey() + entry2.getKey();
                float rCoefficient = entry1.getValue() * entry2.getValue();
                if (rCoefficient == 0.0f) continue;
                if (result.containsKey(rExponent))
                    result.put(rExponent, result.get(rExponent) + rCoefficient);
                else result.put(rExponent, rCoefficient);
            }
        }
        System.out.print(result.size());

        for (Map.Entry<Integer, Float> entry : result.entrySet()) {
            System.out.print(" " + entry.getKey() + " ");
            System.out.printf("%.1f", entry.getValue());
        }
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值