PAT甲级1007 Maximum Subsequence Sum 测试点5不通过解决

1007 Maximum Subsequence Sum

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

算法关键:

具有最大和的子序列不可能以负数开头,也不可能以和为负数的序列开头。

注意:

  1. 当输入的数字全部为负数时,输出最大和为0,并输出输入序列的第一个和最后一个元素;
  2. 一定要考虑当最大和为0的情况(刚开始没考虑的时候会显示测试点5不通过),如:
5
-1 0 -1 -1 -1

应输出:0 0 0

  1. 关于BufferedReader和Scanner
    使用BufferedReader输入一些字符之外的数据比较麻烦需要进行一些相应的转换,但是通过一些OJ系统上的和Scanner作对比,BufferedReader的效率要比Scanner高一倍。
    刚开始使用Scanner进行输入数据,但是最后一个测试点总会提醒运行超时,修改为使用BufferedReader可以解决问题。

代码如下:

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class MaximumSubsequenceSum {

    public static void main(String[] args) throws IOException {
        BufferedReader bufferedReader = new BufferedReader(new InputStreamReader(System.in));
        int number = Integer.parseInt(bufferedReader.readLine());
        int[] array = new int[number];
        String[] strings = bufferedReader.readLine().split(" ");
        for (int i = 0; i < number; i++)
            array[i] = Integer.parseInt(strings[i]);
        int maxSum = 0;
        int start = array[0];
        int end = array[number - 1];
        int s = 0;
        int tempSum = 0;
        for (int i = 0; i < number; i++) {
            tempSum += array[i];
            if (tempSum < 0) {
                tempSum = 0;
                s = i + 1;
            } else if (tempSum > maxSum) {
                maxSum = tempSum;
                start = array[s];
                end = array[i];
            } else if (tempSum == maxSum && tempSum == 0) {//处理最大和为0的情况,暂时还没想到更好的处理办法
                start = array[s];
                end = array[i];
            }
        }
        System.out.print(maxSum + " " + start + " " + end);
    }
}
  • 6
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值