蓝桥杯 18省赛 B8 日志统计(TreeMap)
标题:日志统计
小明维护着一个程序员论坛。现在他收集了一份"点赞"日志,日志共有N行。其中每一行的格式是:
ts id
表示在ts时刻编号id的帖子收到一个"赞"。
现在小明想统计有哪些帖子曾经是"热帖"。如果一个帖子曾在任意一个长度为D的时间段内收到不少于K个赞,小明就认为这个帖子曾是"热帖"。
具体来说,如果存在某个时刻T满足该帖在[T, T+D)这段时间内(注意是左闭右开区间)收到不少于K个赞,该帖就曾是"热帖"。
给定日志,请你帮助小明统计出所有曾是"热帖"的帖子编号。
【输入格式】
第一行包含三个整数N、D和K。
以下N行每行一条日志,包含两个整数ts和id。
对于50%的数据,1 <= K <= N <= 1000
对于100%的数据,1 <= K <= N <= 100000 0 <= ts <= 100000 0 <= id <= 100000
【输出格式】
按从小到大的顺序输出热帖id。每个id一行。
【输入样例】
7 10 2
0 1
0 10
10 10
10 1
9 1
100 3
100 3
【输出样例】
1
3
资源约定:
峰值内存消耗(含虚拟机) < 256M
CPU消耗 < 1000ms
=================
思路:
按固定时间区间查找点赞数->对时间来波快排
对时间快排的同时,还要保存其对于点赞数的映射->使用键值对,而非二维数组
时间作为键值会重复(时间可能出现重复)->使用TreeMap并在构造时候传入Comparator对象并快速重写其compare(),使得主键可重
遍历键值对->Map.Entry< >
public class Treemap_日志统计_8{
static int d ,k;
static Map<Integer ,Integer> map;
public static void main(String[] args) {
init();
List<Integer> tmp =new ArrayList<Integer>();
for(int i =1 ;i <=100000 ;i ++) {
tmp.clear();
for(Map.Entry<Integer, Integer> e :map.entrySet()) if(e.getKey() ==i) tmp.add(e.getValue());
if(tmp.size() <k) continue;
Collections.sort(tmp);
//这里的'tmp.get(end) -tmp.get(bgn) <d'只能是'<'
for(int bgn =0 ,end =k -1 ;end <tmp.size() ;bgn ++ ,end ++) if(tmp.get(end) -tmp.get(bgn) <d) {System.out.println(i); break;}
}
}
private static void init() {
map =new TreeMap<Integer ,Integer>(new Comparator<Integer>(){
@Override
public int compare(Integer o1, Integer o2) { return 1;}
});
Scanner sc = new Scanner(System.in);
int n =sc.nextInt();
d =sc.nextInt();
k =sc.nextInt();
int di =0 ,ki =0;
for(int i =0 ;i <n ;i ++) {di =sc.nextInt() ;ki =sc.nextInt(); map.put(ki, di);}
sc.close();
}
}