844. 走迷宫
给定一个 n×m 的二维整数数组,用来表示一个迷宫,数组中只包含 0 或 1,其中 0 表示可以走的路,1 表示不可通过的墙壁。
最初,有一个人位于左上角 (1,1) 处,已知该人每次可以向上、下、左、右任意一个方向移动一个位置。
请问,该人从左上角移动至右下角 (n,m) 处,至少需要移动多少次。
数据保证 (1,1) 处和 (n,m) 处的数字为 0,且一定至少存在一条通路。
输入格式
第一行包含两个整数 n 和 m。
接下来 n 行,每行包含 m 个整数(0 或 1),表示完整的二维数组迷宫。
输出格式
输出一个整数,表示从左上角移动至右下角的最少移动次数。
数据范围
1≤n,m≤100
输入样例:
5 5
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
输出样例:
8
BFS模板:
代码:
#include<iostream>
#include <cstring> //memset
#include<algorithm>
#include <queue>
using namespace std;
typedef pair<int, int> PII;
int n;
int m;
int g[110][110];
int helper[110][110];
PII op[] = {{-1,0},{1,0},{0,1},{0,-1}};
int bfs(){
queue<PII> q;
int step = 0;
helper[0][0] = 0;
q.push({0,0});
while(q.size()){
auto cur = q.front();
q.pop();
for(int i = 0; i<4; i++){
int x = cur.first+op[i].first, y = cur.second+op[i].second;
if(x>=0&&y>=0&&x<n&&y<m&&helper[x][y]==-1&&g[x][y]==0){
q.push({x,y});
helper[x][y] = helper[cur.first][cur.second]+1;
}
}
}
return helper[n - 1][m - 1];
}
int main()
{
memset(helper,-1,sizeof helper);
cin >> n >> m;
for (int i = 0; i < n; i ++ )
for (int j = 0; j < m; j ++ )
cin >> g[i][j];
cout << bfs() << endl;
return 0;
}
845. 八数码
在一个 3×3 的网格中,1∼8 这 8 个数字和一个 x 恰好不重不漏地分布在这 3×3 的网格中。
例如:
1 2 3
x 4 6
7 5 8
在游戏过程中,可以把 x 与其上、下、左、右四个方向之一的数字交换(如果存在)。
我们的目的是通过交换,使得网格变为如下排列(称为正确排列):
1 2 3
4 5 6
7 8 x
例如,示例中图形就可以通过让 x 先后与右、下、右三个方向的数字交换成功得到正确排列。
交换过程如下:
1 2 3 1 2 3 1 2 3 1 2 3
x 4 6 4 x 6 4 5 6 4 5 6
7 5 8 7 5 8 7 x 8 7 8 x
现在,给你一个初始网格,请你求出得到正确排列至少需要进行多少次交换。
输入格式
输入占一行,将 3×3 的初始网格描绘出来。
例如,如果初始网格如下所示:
1 2 3
x 4 6
7 5 8
则输入为:1 2 3 x 4 6 7 5 8
输出格式
输出占一行,包含一个整数,表示最少交换次数。
如果不存在解决方案,则输出 −1。
输入样例:
2 3 4 1 5 x 7 6 8
输出样例
19
思路:其实是一个经典的BFS问题,只不过由地图变成了状态。其实BFS问题本质上是状态的转变与到达,地图只是一种形式。
代码:
#include <iostream>
#include <algorithm>
#include <unordered_map>
#include <queue>
using namespace std;
pair<int, int> op[] = { {1,0},{-1,0},{0,1},{0,-1} };
int bfs(const string& state) {
string end = "12345678x";
// printf("%p\n",&end);
queue<string> q;
q.push(state);
// printf("%p\n",&(q.front()));
unordered_map<string, int> d;
d[state] = 0;
while (q.size()) {
string cur = q.front();
if (cur == end) return d[end];
q.pop();
int pst = cur.find('x'); //当前的字符串
for (int i = 0; i < 4; i++) {
string s(cur);
int x = pst / 3 + op[i].first, y = pst % 3 + op[i].second; //新的xy坐标
if (x < 3 && y < 3 && x >= 0 && y >= 0) {
swap(s[x * 3 + y], s[pst]); //新的状态
if (!d.count(s)) {//问题:为什么加这个判断,不加会怎么样
d[s] = d[cur] + 1;
q.push(s);
}
}
}
}
return -1;
}
int main()
{
char s;
string state;
for (int i = 0; i < 9; i++)
{
cin >> s;
state += s;
}
cout << bfs(state) << endl;
return 0;
}
问题1:
为什么加这个判断,不加会怎么样?
数据会被污染。比如这个状态之前到达过,后面的其他状态可能绕路也会到达这个状态。若发生了这种情况,存储在Map中表示该状态的distance就会被更新为更长的。
那为什么不需要判断大小更新呢?因为先前到达的状态肯定distance要小于后面到达的状态。所以不需要比较也知道前面就到达的状态distance要更小。也就是最小路径
问题2:
初学C++, 容器保存的是复制了的字符串还是保存的是地址呢?
这里比较了两个地址,结果是不同的,因此可以判断,容器保存的是复制后的变量地址,是重新开辟的地址。 要多看STL源码。