每日一道算法题 Day7 of PAT 1008 Elevator (20分)

1008 Elevator (20分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

前天上体育课网课,还要求拍视频,当时没觉得什么,上蹦下跳了一个小时,结果昨天肌肉酸痛,写题缺了一天,今天补上。。。。。。

这道题乍一看还以为是求最优解,害得我还紧张了一小会,然后仔细看了下题目,不就是循环赋值最后输出吗?没什么东西

如果非要讲点东西出来的话,那就是写循环注意看清楚题目中的起始条件

Attention:

  • 注意起始条件

Details:

Code:

#include <bits/stdc++.h>
using namespace std;
int main(){
	int reqNum;
	int current=0;
	int next;
	int totalTime=0;
	cin>>reqNum;
	for(int i=0;i<reqNum;i++){
		cin>>next;
		totalTime+=5;
		if(next>current){
			totalTime+=(6*(next-current));
		}else if(next<current){
			totalTime+=(4*(current-next));
		}
		current=next;
	}
	cout<<totalTime;
	return 0;
} 

Summary and harvest

(for my current level)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值