简单数学-题解-Trailing Zeroes (III)

Trailing Zeroes (III)

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 12…*N. For example, 5! = 120, 120 contains one zero on the trail.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.
Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output For each case, print the case number and N. If no solution is found then print ‘impossible’.

Sample Input
3

1

2

5

Sample Output
Case 1: 5

Case 2: 10

Case 3: impossible

用二分找

#include<iostream>
#include<cstdio>
#include<queue>
#include<string>
#include<string.h>
#include<cmath>
#include<algorithm>
#include<map>
using namespace std;

long long f(long long m){
	long long ans=0;
	while(m>=5){
		ans+=m/5;
		m/=5;
	}
	return ans;
}


int main ()
{
	int t,o=1;
	scanf("%d",&t);
	while(t--){
		long long q;
		scanf("%lld",&q);
//		printf("%lld\n",f(q));
		long long i=4,j=4000000000000000025;
		while(j-i>1){
			long long mid=(i+j)>>1;
			if(f(mid)>=q) j=mid;
			else i=mid;
		}
		if(f(j)==q)
			printf("Case %d: %lld\n",o++,j);
		else
			printf("Case %d: impossible\n",o++);
	}
	return 0 ;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值