Triangle(斐波那锲数列)

Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3⋯n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.
Input
The first line contains only one integer T (T≤20), which indicates the number of test cases.

For each test case, there is only one line describing the given integer n (1≤n≤20).

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.

Sample Input3
4
5
6

Sample Output
Case #1: 1
Case #2: 1
Case #3: 2

题目大意:给你长度1-n的小棍(顺序就是1-n),让你计算最少拿掉多少根小棍构不成1个三角形。

分析:我第一眼看到这个题一看数据不大,直接把1-20 给写了出来。

请看暴力AC代码:

#include<iostream>
using namespace std;
typedef long long ll;
const int mmax=1e6+10;
int main()
{
	 int a[21]={0,0,0,0,1,1,2,3,3,4,5,6,7,7,8,9,10,11,12,13,14};
	 int t,k=1;
	 cin>>t;
	 while(t--)
	 {
		 int n;
	  	cin>>n;
	  	printf("Case #%d: %d\n",k++,a[n]);
	 } 
	 return 0;
}

正解:构成三角形的一个条件是两边之和大于第三边
先写几个数字
4:1 2 3 4 4不行
5:1 2 3 4 5 4 不行
6: 1 2 3 4 5 6 4 6 不行
7:1 2 3 4 5 6 7 4 6 7 不行

发现数列中只存在斐波那锲数列的时候构不成任何三角形
有了这个思想就简单了 把1-n中斐波那锲数列的个数求出来 ,然后用 n-sum[n]就是答案

#include<iostream>
using namespace std;
int sum[30];
void init()
{
	 int a=1,b=2;
	 sum[1]=1;
	 sum[2]=2;
	 int num=2;
	 for(int i=3;i<=30;i++)
	 {
		  if(a+b==i)
		  {
			   num++;
			   sum[i]=num;
			   a=b;
			   b=i;
		  }
		  else
		  	 sum[i]=num;
		 }
	}
int main()
{
	init();
	// for(int i=1;i<=20;i++)
	//  cout<<sum[i]<<" ";
	// cout<<endl;
	int t,k=1;
	cin>>t;
	while(t--)
	{
		 int n;
		 cin>>n;
		 cout<<"Case #"<<k++<<": "<<n-sum[n]<<endl;
	}
	return 0;
}
	```
	
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

aaHua_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值