POJ1426-Find The Multiple

题目:
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

分析:
题目是要我们求一个只有1和0组成的整数并且能把输入的数字给整除,可以存在特殊解。同样遍历该数字乘10和该数字乘10 加 1两种状态,所以用bfs。因为0是不可行的解,所以我们可以传入1,又因为题目题目规定了整数的长度,所以我们可以设置一个depth变量来间接的记录该数字的长度。当depth == 19时即退出。
至于为什么设置leap,我的理解是防止重复计算,遇到可行解就立马退出。

代码:

#include <iostream>
using namespace std;

int n;
bool leap;
long long ans;
//超出int12位数字,在64位系统中,long 和 int等长。所以用long long
void dfs(long long temp, int depth) {
	if (depth == 19) return;//边界判断
	else if (leap) return;
	else if (temp % n == 0) {
		ans = temp;
		leap = true;
		return;
	}
	//递归遍历两种状态
	dfs(temp * 10, depth + 1);
	dfs(temp * 10 + 1, depth + 1);
}
int main() {
	while (cin >> n && n) {
		leap = false;
		dfs(1, 0);
		cout << ans << endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值