PAT甲级1154

1154 Vertex Coloring (25 分)

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

代码

#include <iostream>
#include <stdio.h>
#include <vector>
#include <set>
using namespace std;
struct node
{
	int color;
	vector<int> next;
}node[10000];
int nodeNum;
int flag = 0;
set<int> s;
void bfs()
{
	for(int i = 0; i < nodeNum; i++){
		int start = node[i].color;
		s.insert(start);
		for(int j = 0; j < node[i].next.size(); j++){
			int end = node[node[i].next[j]].color;
			if(start == end){
				flag = -1;
				break;
			}
			s.insert(end);
		}
	}
}
int main()
{
	int edgeNum;
	scanf("%d %d", &nodeNum, &edgeNum);
	for(int i = 0; i < edgeNum; i++){
		int c, d;
		scanf("%d %d", &c, &d);
		node[c].next.push_back(d);
	}
	int e;
	scanf("%d", &e);
	for(int i = 0; i < e; i++){
		for(int j = 0; j < nodeNum; j++){
			sacnf("%d", &node[j].color);
		}
		bfs();
		if(flag == -1)
			printf("No\n");
		else
			printf("%d-coloring\n",s.size());
		flag = 0;
		s.clear();
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值