入门

单调栈的性质:
(1):栈中元素是单调递增或单调递减的
(2):后进先出
应用:求某一元素左(右)边第一个比它大(小)的值。

Description
Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people’s memories about some period of life.
A new idea Bill has recently developed assigns a non-negative integer value to each day of human
life. Bill calls this value the emotional value of the day. The greater the emotional value is, the better
the day was. Bill suggests that the value of some period of human life is proportional to the sum of the
emotional values of the days in the given period, multiplied by the smallest emotional value of the day
in it. This schema reflects that good on average period can be greatly spoiled by one very bad day.
Now Bill is planning to investigate his own life and find the period of his life that had the greatest
value. Help him to do so.
Input
The input will contain several test cases, each of them as described below. Consecutive test cases are
separated by a single blank line.
The first line of the input file contains n — the number of days of Bill’s life he is planning to
investigate (1 ≤ n ≤ 100000). The rest of the file contains n integer numbers a1, a2, . . . , an ranging
from 0 to 106 — the emotional values of the days. Numbers are separated by spaces and/or line breaks.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases
will be separated by a blank line.
On the first line of the output file print the greatest value of some period of Bill’s life.
On the second line print two numbers l and r such that the period from l-th to r-th day of Bill’s
life (inclusive) has the greatest possible value. If there are multiple periods with the greatest possible
value, then print any one of them.
Sample Input
6
3 1 6 4 5 2
Sample Output
60
3 5

题意:求一个区间,使得区间和乘上区间最小值最大。输出该值和区间的l,r(要输出区间长度最短的,区间长度一样输出左端点最左的)。

做法:设计一个结构体,x代表值,id代表下标,l、r代表以当前值为区间最小值时的最长区间的最左端和最右端,维护一个单调递减的栈。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stack>
using namespace std;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int maxn = 100005;

typedef struct
{
   
    int l,r,id;
    ll x;
}node;
node a[maxn];
ll sum[maxn];

int main()
{
   
    int n;
    int num=1;
    while(scanf("%d",&n) != EOF)
    {
   
        memset(a,0,sizeof(a));
        memset(sum,0,sizeof(sum));
        for(int i=1; i<=n; i++)
        {
   
            scanf("%lld",&a[i].x);
            a[i].id = i
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值