厦门理工学院OJ 1377.字符串统计 (map)

Description

输入若干行字符串,输出出现次数最多的一条字符串。

Input

输入数据的第一行有一个整数N,表示有N行字符串(1 < N < 10^6)。
接下来有N行字符串,字符串只包含小写字母,长度不大于 100 , 不重复的字符串数目不超过 1000 。

Output

输出出现次数最多的一条字符串,数据保证结果唯一。

Sample Input

3
asdfghjkl
asdfghjkl
fefeff

Sample Output

asdfghjkl

题解

使用stl::map直接计数即可。

代码

#include<iostream>
#include<string>
#include<map>
#include<algorithm>
using namespace std;

class cmp{
public:
	bool operator () (const pair<string,int> &a, const pair<string,int> &b){
		return a.second<b.second; 
	}
};

int main(){
	ios::sync_with_stdio(0);
	cin.tie(0);
	int n;
	cin>>n;
	string s;
	map<string,int> m;
	while(n--){
		cin>>s;
		m[s]++;
	}
	cout<<max_element(m.begin(),m.end(),cmp())->first<<endl;
	return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值