HDU - 4135 Co-prime(容斥原理)

原题链接

Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
Sample Input
2
1 10 2
3 15 5
Sample Output
Case #1: 5
Case #2: 10

Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.

题意:求a-b间与n互质的数有多少个。

思路:求1-n与n互质的数的个数即n的欧拉函数值,但是这里显然不适用。直接求互质的个数不好求,那么就求不互质的个数,分别求出1-(a-1), 1-b与n不互质数的个数numa,numb,前缀和思想求得答案。
那么答案即为b-(a-1)-(numb-numa)。

上面求不互质数的过程,可以利用容斥原理,先将n分解质因数,然后这些质因数的倍数都与b不互质,质因数中几个或多个的乘积的倍数也与b不互质,但是期间可能会重复,比如6是2和3的倍数,也是2 * 3的倍数,这样就被算了两次,要减掉,同理两个数的组合都被减掉,那么2 * 3 * 5,在2, 3, 5的时候加了三次,2 * 3, 3 * 5, 2 * 5的时候减了三次,相当于没有算,所以2 * 3 * 5的倍数要被加上。(其实就是容斥原理,奇数个加上,偶数个减去

参考博客

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long ll;
ll a[3005],cnt;
void init(int n)
{
	cnt=0;
	for(int i=2;i<=n/i;i++)
	{
		if(n%i==0)
		{
			a[cnt++]=i;
			while(n%i==0) n/=i;
		}
	}
	if(n>1) a[cnt++]=n;
}
ll solve(ll n)
{
	ll ans=0;
	for(int i=1;i<(1<<cnt);i++)
	{
		ll num=0,t=1;
		for(int j=0;j<cnt;j++)
		{
			if(i&(1<<j))
				t*=a[j],num++;
		}
		if(num&1) ans+=n/t;
		else ans-=n/t;
	}
	return ans;
}
int main()
{
	int t,cas=1;
	cin>>t;
	while(t--)
	{
		ll a,b,n;
		cin>>a>>b>>n;
		printf("Case #%d: ",cas++);
		init(n);
		cout<<b-(a-1)-(solve(b)-solve(a-1))<<endl;
	}
	return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值