Knapsack problem(01背包变形)

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input
The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+…+v[n] <= 5000

All the inputs are integers.

Output
For each test case, output the maximum value.

Sample Input
1
5 15
12 4
2 2
1 1
4 10
1 2
Sample Output
15

前阵子刚学的背包正好用上了,hhh,正好来记录一下,巩固巩固

思路:一看给的w[i]到了1e9,那么之前01背包的做法枚举空间就肯定不行了,那么枚举价值就完事了,让价值大的情况下占的空间尽量小。需要注意的是初始化要初始成无穷大,但是dp[0]要等于0。

#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
ll dp[5005];
int w[505];
int v[505];
int main()
{
	int t,n,m,sum;
	scanf("%d",&t);
	while(t--)
	{
		sum=0;
		memset(dp,inf,sizeof(dp));
		dp[0]=0;
		scanf("%d%d",&n,&m);
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&w[i],&v[i]);
			sum+=v[i];
		}
		//cout<<sum<<endl;
		for(int i=1;i<=n;i++)
		{	
			for(int j=sum;j>=v[i];j--)
				dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
		}
		for(int i=sum;i>=0;i--)
			if(dp[i]<=m)
			{
				cout<<i<<endl;
				break;
			}
	}
	return 0;
 } 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值