Nim or not Nim? HDU - 3032 (Nim博弈变形)

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], …, s[N-1], representing heaps with s[0], s[1], …, s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
Output
For each test case, output a line which contains either “Alice” or “Bob”, which is the winner of this game. Alice will play first. You may asume they never make mistakes.
Sample Input
2
3
2 2 3
2
3 3
Sample Output
Alice
Bob

题意:n堆石子,每次操作从任意一堆中取任意个(至少一个),或者把任意一堆石子变成更小的两堆。

思路:和原nim游戏其实差不多,只不过原nim游戏它每一堆的sg值就是它本身,这个题发生了一些变化,那么就找找规律,发现如果石子数k%4=1或者2的话,sg值就等于它本身,如果%4=3的话等于k+1,如果%4=0的话等于
k-1,那么将所有石子数的sg值异或起来看是否为0就行了

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
/*int sg[1005];
int get_sg(int x)
{
	if(sg[x]!=-1)
		return sg[x];
	int vis[1005];
	memset(vis,0,sizeof vis);
	for(int i=1;i<=x;i++)
		vis[get_sg(x-i)]=1;
	for(int i=1;i<=x/2;i++)
	{
		vis[get_sg(i)^get_sg(x-i)]=1;
	}
	for(int i=0;;i++)
		if(!vis[i])
			return sg[x]=i;
}
int main()
{
	memset(sg,-1,sizeof sg);
	get_sg(100);
	for(int i=1;i<=100;i++)
	{
		printf("sg[%d]: %d\n",i,sg[i]);
	}
	return 0;
 } */
 int main()
 {
 	int t;
 	cin>>t;
 	while(t--)
 	{
 		int n,ans=0;
 		cin>>n;
 		for(int i=0;i<n;i++)
 		{
 			int x;
 			scanf("%d",&x);
 			if(x%4==3)
 				ans^=(x+1);
 			else if(x%4==0)
 				ans^=(x-1);
 			else 	
 				ans^=x;
		 }
		 if(!ans)
		 	printf("Bob\n");
		else 
			printf("Alice\n");
	 }
 	return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值