POJ.2253.Frogger

Frogger(dijkstra算法)

Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:湖中有n块石头,编号从1到n,有两只青蛙,Bob在1号石头上,Alice在2号石头上,Bob想去看望Alice,但由于水很脏,他想避免游泳,于是跳着去找她。但是Alice的石头超出了他的跳跃范围。因此,Bob使用其他石头作为中间站,通过一系列的小跳跃到达她。两块石头之间的青蛙距离被定义为两块石头之间所有可能路径上的最小必要跳跃距离,某条路径的必要跳跃距离即这条路径中单次跳跃的最远跳跃距离。你的工作是计算Alice和Bob石头之间的青蛙距离。

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxx = 210;
int vis[maxx];
double g[maxx][maxx];
double cot[maxx];
int n;
struct juli{//坐标算距离
	double x, y;
};
double dijkstra(){
	for (int i = 1; i <= n; i++)
		cot[i] = g[1][i], vis[i] = 0;
	for (int i = 1; i <= n; i++){
		double _min = INF;int  k = 0;
		for (int j = 1; j <= n; j++)
			if (!vis[j] && cot[j] < _min)
				_min = cot[j], k = j;
		vis[k] = 1;
		for (int j = 1; j <= n; j++)
			if (!vis[j] && cot[j] > max(_min, g[k][j]))
//_min相当于cot[k],另外g[k][j],即能到j点方案时最大的那条边与直接到这条边的值作比较
				cot[j] = max(_min, g[k][j]);
	}
	return cot[2];//去的是二号石头
}
int main(){
	int T = 0;
	while (~scanf("%d", &n) &&n){
		T++;
        juli p[maxx];
		memset(g, 0, sizeof(g));
		memset(cot, 0, sizeof(cot));
		for (int i = 1; i <= n; i++)
			scanf("%lf%lf", &p[i].x, &p[i].y);
		for (int i = 1; i <= n; i++)
			for (int j = i; j <= n; j++)//求任意两边距离,即代价
				g[i][j] = g[j][i] = sqrt((p[i].x - p[j].x)*(p[i].x - p[j].x)
				+ (p[i].y - p[j].y)*(p[i].y - p[j].y));
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n", T, dijkstra());
	}
	return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值