(HDU-1241-Oil Deposits)DFS油田问题

2 篇文章 0 订阅

题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1241

HDU-1241-Oil Deposits
Oil Deposits Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 48265 Accepted Submission(s): 27762

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is ‘*’ either representing the absence of oil, or’@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
@@*
@
@@*
1 8
@@***@
5 5
****@
@@@
@**@
@@@
@
@@**@
0 0

Sample Output

0
1
2
2


这是一个很经典的入门级DFS题目了,我也是从这个题目入门的DFS!!! 以下是我第一次写DFS的代码,思路在注释里写明了
#include <iostream>
#include <cstring>
using namespace std;

const int MAX = 100;
int n,m;
char arr[MAX][MAX];
int ans;

void dfs(int x,int y)
{

    arr[x][y] = '*';            //这一步很关键,表示如果找到油田则标记为*,下次查找到关联的油田就ans就不会++了
    if(arr[x-1][y-1]=='@')      //以下是查找周围八个方向的油田数目
        dfs(x-1,y-1);
    if(arr[x][y-1]=='@')
        dfs(x,y-1);
    if(arr[x+1][y-1]=='@')
        dfs(x+1,y-1);
    if(arr[x-1][y]=='@')
        dfs(x-1,y);
    if(arr[x+1][y]=='@')
        dfs(x+1,y);
    if(arr[x+1][y+1]=='@')
        dfs(x+1,y+1);
    if(arr[x][y+1]=='@')
        dfs(x,y+1);
    if(arr[x-1][y+1]=='@')
        dfs(x-1,y+1);

}

int main()
{
    while(cin>>n>>m&&n&&m)      //n,m分别代表行和列
    {
        memset(arr,0,sizeof(arr));     //把所有元素初始化为0,然后从第一行第一列开始输入数据,后面就不用进行边界判断了
        for(int i=1; i<=n; i++)         //输入代表有无油田的符号*@
            for(int j=1; j<=m; j++)
                cin >> arr[i][j];
        for(int i=1; i<=n; i++)      //循环遍历油田
            for(int j=1; j<=m; j++)
                if(arr[i][j]=='@')    //如果找到油田
                {
                    ans++;     //油田数目+1
                    dfs(i,j);     //进入函数查找周围八个地方的油田
                }
        cout << ans << endl;
        ans=0;
    }
    return 0;
}


    



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值