HDU1241 经典油田问题(DFS)

先粘个原题:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits.
GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides
the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to
determine whether or not the plot contains oil.
A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the
same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to
determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number
of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting
the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the
absence of oil, or ‘@’, representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same
oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
* *@* *
*@*@*
1 8
@@ * * * * @ *
5 5
* * * * @
* @@*@
* @ * * @
@@@*@
@@* * @
0 0
Sample Output
0
1
2
2

题目大致意思是在一块m * n的范围内用“@”标记油田,用“ * ”标记不存在油田的位置。假如一个点被标记为油田,那么这个点的周围九宫格范围内如果还存在油田,这两个油田就是一块油田,问给出的图中油田的块数。基本思路就是先遍历,一旦找到一处油田进入DFS递归,将这个油田所在的一整块油田全部标记,计数器加一。之后遍历继续,直至每块油田均被标记,代码如下。其中注释部分是从 BJFU 1143小蝌蚪找妈妈那道题的模板挪过来的,不同之处就在于那道题只有上下左右四个方向,而这道题有八个方向。

#include<iostream>
#include<cstring>
using namespace std;
int a[105][105];
int n,m,ans=0,man=0;

void dfs(int i,int j)
{
	if(a[i][j]==1)
		{
			// man++;
			// if(man>ans)
			// ans=man;
			a[i][j]=0;
			if(i-1>0) dfs(i-1,j);			
			if(j-1>0) dfs(i,j-1);
			if(i+1<=n) dfs(i+1,j);
			if(j+1<=m) dfs(i,j+1);
			if(i-1>0&&j-1>0) dfs(i-1,j-1);			
			if(i-1>0&&j+1<=m) dfs(i-1,j+1);
			if(i+1<=n&&j-1>0) dfs(i+1,j-1);
			if(i+1<=m&&j+1<=m) dfs(i+1,j+1);

		}
}
int main()
{	
	//freopen("1.txt","r",stdin);
	while(cin>>n>>m&&(m||n))
	{
		int num = 0;
		if(n == 0&&m == 0)return 0;
		int i,j;
		char w;
		ans=0;
		memset(a,0,sizeof(a));
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
			{
				cin>>w;
				if(w=='@')
				a[i][j]=1;
			}      //读出原图并标记
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
			{
				if(a[i][j]==1)
				{
					num++;
					// man=0;
					dfs(i,j);
				}
			}
		cout<<num<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值