PAT 1043 Is It a Binary Search Tree (25 分)

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NNN (≤1000\le 10001000). Then NNN integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

代码:

#include <cstdio>
#include <vector> 
using namespace std;

struct node{
	int data ;
	node* lchild;
	node* rchild;
};

node* newNode(int x){
	node* root = new node;
	root->data = x;
	root->lchild = root->rchild = NULL;
	return root;
}

void insert(node* &root,int x){
	if(root == NULL){
		root = newNode(x);
		return;
	}else if(x < root->data){
		insert(root->lchild,x);
	}else if(x >= root->data){
		insert(root->rchild,x);		
	}
}

void preOrder(node* root,vector<int> &vi){
	if(root == NULL){
		return ;
	}
	vi.push_back(root->data);
	preOrder(root->lchild,vi);
	preOrder(root->rchild,vi);
}

void preOrderMirror(node* root,vector<int> &vi){
	if(root == NULL){
		return ;
	}
	vi.push_back(root->data);
	preOrderMirror(root->rchild,vi);
	preOrderMirror(root->lchild,vi);
}

void postOrder(node* root,vector<int> &vi){
	if(root == NULL){
		return ;
	}
	postOrder(root->lchild,vi);
	postOrder(root->rchild,vi);
	vi.push_back(root->data);
}

void postOrderMirror(node* root,vector<int> &vi){
	if(root == NULL){
		return ;
	}
	postOrderMirror(root->rchild,vi);
	postOrderMirror(root->lchild,vi);
	vi.push_back(root->data);
}
vector<int> origin,pre,preM,post,postM;

int main(){
	int n,data;
	scanf("%d",&n);
	node* root =NULL;
	for (int i = 0 ; i < n ; i++){
		scanf("%d",&data);
		origin.push_back(data);
		insert(root,data);
	}
	
	preOrder(root,pre);
	preOrderMirror(root,preM);
	postOrder(root,post);
	postOrderMirror(root,postM);
	
	if(origin == pre){
		printf("YES\n");
		for(int i = 0 ; i < post.size() ; i++){
			printf("%d",post[i]);
			if(i != post.size()-1)
				printf(" ");
		}		
	}else if(origin == preM){
		printf("YES\n");
		for(int i = 0 ; i < postM.size() ; i++){
			printf("%d",postM[i]);
			if(i != postM.size()-1)
				printf(" ");
		}	
	}else{
		printf("NO\n");
	}
	
	return 0;
}

总结:

       对于一个二叉排序树来说,其先序遍历的结果等于其原始插入顺序。 因此给定一个序列使用其建树,若其先序遍历的结果和原始插入序列相同,则可以判断为二叉排序树。


乱七八糟的日常:

下面是嘟嘟推荐的很不错的一个酒吧,长沙的小伙伴可以去试试,(# ^ . ^ #):
在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值