Catch That Cow

 

 

Problem Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

这道题也就是三个方向,前进一步,后退一步,以及传送到二倍的位置,然后就是正常的BFS

#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
int vis[100010],step[100010];
int bfs(int s,int z)
{
    queue<int>q;
    q.push(s);
    vis[s]=1;
    step[1]=0;
    while(!q.empty())
    {
        int k=q.front();
        q.pop();
        if(k==z)
        {
            return step[k];//如果到达终点那么输出此时的步数
        }
        else
        {
            if(!vis[k+1]&&k+1>=0&&k+1<=100000)
            {
                q.push(k+1);
                vis[k+1]=1;
                step[k+1]=step[k]+1;
            }
            if(!vis[k-1]&&k-1>=0&&k-1<=100000)
            {
                q.push(k-1);
                vis[k-1]=1;
                step[k-1]=step[k]+1;
            }
            if(k*2>=0&&k*2<=100000&&!vis[k*2])
            {
                q.push(k*2);
                vis[k*2]=1;
                step[k*2]=step[k]+1;
            }
        }
    }
    return 0;
}
int main()
{
    int n,k;
    while(cin>>n>>k)
    {
        memset(vis,0,sizeof(vis));
        memset(step,0,sizeof(step));
        int ans=bfs(n,k);
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值