Catch That Cow (经典广搜入门题)

Catch That Cow

 

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题意简介:农夫追牛,牛不动,农夫有两种移动方式,第一种:前或后移动一步;第二种:农夫现在的位置X2;每次移动都消耗1分钟,求农夫追到牛的最短时间。

#include<cstdio>
#include<iostream>
#include<queue>
#include<algorithm>

#define MAXN 1000001
using namespace std;

int ret[MAXN],vis[MAXN];
queue<int> p;

int bfs(int n,int k)
{
	int cur;
	if(n==k) return 0;
	p.push(n);
	
	while(!p.empty()){
		cur=p.front();
		p.pop();
		
		if(cur+1<MAXN && vis[cur+1]!=1){
			ret[cur+1]=ret[cur]+1;          //步数加1 
			vis[cur+1]=1;                   //标记是否已经读取过 
			p.push(cur+1);                  //将这个符合条件的点放入队列 
		}
		if(cur+1 == k) break;               //如果已经追上,则结束,并返回 
		
		if(cur-1>=0 && vis[cur-1]!=1){      //以下同上 
			ret[cur-1]=ret[cur]+1;
			vis[cur-1]=1;
			p.push(cur-1);
		}
		if(cur-1 == k) break;
		
		if(cur*2<MAXN && vis[cur*2]!=1){
			ret[cur*2]=ret[cur]+1;
			vis[cur*2]=1;
			p.push(cur*2);
		}
		if(cur*2 == k) break;	
	}
	return ret[k];
}

int main()
{
	int N,K;
	cin>>N>>K;
	printf("%d\n",bfs(N,K));
	return 0;
}



  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值