杭电OJ Problem-1002

杭电OJ Problen-1002

杭电OJ problem-1002 A+B problem2

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

Author

Ignatius.L

已解决

#include<stdio.h>
#include<string.h>
int main()
{
char s1[1000],s2[1000];
int i,j,n,m;
scanf("%d",&n);
for(i=1;i<=n;i++)
{
int p=0,q=0,lmax=0,d=0;
int k=0;
int a[1001]={0},b[1001]={0},c[1001]={0};
scanf("%s",&s1);
scanf("%s",&s2);
p=strlen(s1),q=strlen(s2);
lmax=p>q?p:q;
for(k=0,j=p-1;j>=0;j--,k++)
   a[k]=s1[j]-'0';
for(j=q-1,k=0;j>=0;j--,k++)
   b[k]=s2[j]-'0';
for(m=0;m<lmax;m++)
{
c[m]=(a[m]+b[m]+d)%10;
d=(a[m]+b[m]+d)/10;
}
printf("Case %d:\n%s + %s = ",i,s1,s2);
if(d>0)
{
c[lmax]=d;
for(j=lmax;j>=0;j--)
   printf("%d",c[j]);
}
else
{for(j=lmax-1;j>=0;j--)
   printf("%d",c[j]);}
if(i!=n)
   printf("\n\n");
else
   printf("\n");
}
return 0;
}










评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值